summaryrefslogtreecommitdiff
path: root/python-xlrd3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-xlrd3.spec')
-rw-r--r--python-xlrd3.spec207
1 files changed, 207 insertions, 0 deletions
diff --git a/python-xlrd3.spec b/python-xlrd3.spec
new file mode 100644
index 0000000..596b234
--- /dev/null
+++ b/python-xlrd3.spec
@@ -0,0 +1,207 @@
+%global _empty_manifest_terminate_build 0
+Name: python-xlrd3
+Version: 1.1.0
+Release: 1
+Summary: Library for developers to extract data from Microsoft Excel (tm) spreadsheet files
+License: BSD
+URL: https://github.com/Dragon2fly/xlrd3
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/79/db/88d8d49ddacc203956ecb98dc86c6ffeee6e933ef1f50da9b369de518f7f/xlrd3-1.1.0.tar.gz
+BuildArch: noarch
+
+
+%description
+### xlrd3
+A fork of original archived [xlrd](https://github.com/python-excel/xlrd) project.
+This fork aims to fix bugs that existing in `xlrd` and improve it features.
+As the name of this fork implies, python2 support is dropped.
+At version 1.0.0, xlrd3 on pair with xlrd version 1.2.0 with following bugs fixed:
+* MemoryError: `on_demand` with `mmap` still causes some `xls` to be read the whole file into memory.
+* `on_demand` not supported for `xlsx`
+* Parsing comments failed for `xlsx` on Windows platform.
+### When to use xlrd3
+If you just need to **read** and deal with both `xlsx` and `xls`, use `xlrd3`.
+Then if you want to export your data to other excel files, use [OpenPyXL](https://openpyxl.readthedocs.io/en/stable/) or [xlsxWriter](https://github.com/jmcnamara/XlsxWriter).
+If you need to **edit** `xlsx` (read and write) and are sure that `xls` never appear in your workflow, you are advised to use [OpenPyXL](https://openpyxl.readthedocs.io/en/stable/) instead.
+**Purpose**: Provide a library for developers to use to extract data from Microsoft Excel (tm) spreadsheet files. It is not an end-user tool.
+**Original Author**: John Machin
+**Licence**: BSD-style (see licences.py)
+**Versions of Python supported**: 3.6+.
+**Outside scope**: xlrd3 will safely and reliably ignore any of these if present in the file:
+* Charts, Macros, Pictures, any other embedded object. WARNING: currently this includes embedded worksheets.
+* VBA modules
+* Formulas (results of formula calculations are extracted, of course).
+* Comments
+* Hyperlinks
+* Autofilters, advanced filters, pivot tables, conditional formatting, data validation
+* Handling password-protected (encrypted) files.
+**Installation**:`$pip install xlrd3`
+**Quick start**:
+```python
+import xlrd3 as xlrd
+book = xlrd.open_workbook("myfile.xls")
+print("The number of worksheets is {0}".format(book.nsheets))
+print("Worksheet name(s): {0}".format(book.sheet_names()))
+sh = book.sheet_by_index(0)
+print("{0} {1} {2}".format(sh.name, sh.nrows, sh.ncols))
+print("Cell D30 is {0}".format(sh.cell_value(rowx=29, colx=3)))
+for rx in range(sh.nrows):
+ print(sh.row(rx))
+```
+**Another quick start**: This will show the first, second and last rows of each sheet in each file:
+ python PYDIR/scripts/runxlrd.py 3rows *blah*.xls
+**Acknowledgements**:
+* This package started life as a translation from C into Python of parts of a utility called "xlreader" developed by David Giffin. "This product includes software developed by David Giffin <david@giffin.org>."
+* OpenOffice.org has truly excellent documentation of the Microsoft Excel file formats and Compound Document file format, authored by Daniel Rentz. See http://sc.openoffice.org
+* U+5F20 U+654F: over a decade of inspiration, support, and interesting decoding opportunities.
+* Ksenia Marasanova: sample Macintosh and non-Latin1 files, alpha testing
+* Backporting to Python 2.1 was partially funded by Journyx - provider of timesheet and project accounting solutions (http://journyx.com/).
+* Provision of formatting information in version 0.6.1 was funded by Simplistix Ltd (http://www.simplistix.co.uk/)
+
+%package -n python3-xlrd3
+Summary: Library for developers to extract data from Microsoft Excel (tm) spreadsheet files
+Provides: python-xlrd3
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-xlrd3
+### xlrd3
+A fork of original archived [xlrd](https://github.com/python-excel/xlrd) project.
+This fork aims to fix bugs that existing in `xlrd` and improve it features.
+As the name of this fork implies, python2 support is dropped.
+At version 1.0.0, xlrd3 on pair with xlrd version 1.2.0 with following bugs fixed:
+* MemoryError: `on_demand` with `mmap` still causes some `xls` to be read the whole file into memory.
+* `on_demand` not supported for `xlsx`
+* Parsing comments failed for `xlsx` on Windows platform.
+### When to use xlrd3
+If you just need to **read** and deal with both `xlsx` and `xls`, use `xlrd3`.
+Then if you want to export your data to other excel files, use [OpenPyXL](https://openpyxl.readthedocs.io/en/stable/) or [xlsxWriter](https://github.com/jmcnamara/XlsxWriter).
+If you need to **edit** `xlsx` (read and write) and are sure that `xls` never appear in your workflow, you are advised to use [OpenPyXL](https://openpyxl.readthedocs.io/en/stable/) instead.
+**Purpose**: Provide a library for developers to use to extract data from Microsoft Excel (tm) spreadsheet files. It is not an end-user tool.
+**Original Author**: John Machin
+**Licence**: BSD-style (see licences.py)
+**Versions of Python supported**: 3.6+.
+**Outside scope**: xlrd3 will safely and reliably ignore any of these if present in the file:
+* Charts, Macros, Pictures, any other embedded object. WARNING: currently this includes embedded worksheets.
+* VBA modules
+* Formulas (results of formula calculations are extracted, of course).
+* Comments
+* Hyperlinks
+* Autofilters, advanced filters, pivot tables, conditional formatting, data validation
+* Handling password-protected (encrypted) files.
+**Installation**:`$pip install xlrd3`
+**Quick start**:
+```python
+import xlrd3 as xlrd
+book = xlrd.open_workbook("myfile.xls")
+print("The number of worksheets is {0}".format(book.nsheets))
+print("Worksheet name(s): {0}".format(book.sheet_names()))
+sh = book.sheet_by_index(0)
+print("{0} {1} {2}".format(sh.name, sh.nrows, sh.ncols))
+print("Cell D30 is {0}".format(sh.cell_value(rowx=29, colx=3)))
+for rx in range(sh.nrows):
+ print(sh.row(rx))
+```
+**Another quick start**: This will show the first, second and last rows of each sheet in each file:
+ python PYDIR/scripts/runxlrd.py 3rows *blah*.xls
+**Acknowledgements**:
+* This package started life as a translation from C into Python of parts of a utility called "xlreader" developed by David Giffin. "This product includes software developed by David Giffin <david@giffin.org>."
+* OpenOffice.org has truly excellent documentation of the Microsoft Excel file formats and Compound Document file format, authored by Daniel Rentz. See http://sc.openoffice.org
+* U+5F20 U+654F: over a decade of inspiration, support, and interesting decoding opportunities.
+* Ksenia Marasanova: sample Macintosh and non-Latin1 files, alpha testing
+* Backporting to Python 2.1 was partially funded by Journyx - provider of timesheet and project accounting solutions (http://journyx.com/).
+* Provision of formatting information in version 0.6.1 was funded by Simplistix Ltd (http://www.simplistix.co.uk/)
+
+%package help
+Summary: Development documents and examples for xlrd3
+Provides: python3-xlrd3-doc
+%description help
+### xlrd3
+A fork of original archived [xlrd](https://github.com/python-excel/xlrd) project.
+This fork aims to fix bugs that existing in `xlrd` and improve it features.
+As the name of this fork implies, python2 support is dropped.
+At version 1.0.0, xlrd3 on pair with xlrd version 1.2.0 with following bugs fixed:
+* MemoryError: `on_demand` with `mmap` still causes some `xls` to be read the whole file into memory.
+* `on_demand` not supported for `xlsx`
+* Parsing comments failed for `xlsx` on Windows platform.
+### When to use xlrd3
+If you just need to **read** and deal with both `xlsx` and `xls`, use `xlrd3`.
+Then if you want to export your data to other excel files, use [OpenPyXL](https://openpyxl.readthedocs.io/en/stable/) or [xlsxWriter](https://github.com/jmcnamara/XlsxWriter).
+If you need to **edit** `xlsx` (read and write) and are sure that `xls` never appear in your workflow, you are advised to use [OpenPyXL](https://openpyxl.readthedocs.io/en/stable/) instead.
+**Purpose**: Provide a library for developers to use to extract data from Microsoft Excel (tm) spreadsheet files. It is not an end-user tool.
+**Original Author**: John Machin
+**Licence**: BSD-style (see licences.py)
+**Versions of Python supported**: 3.6+.
+**Outside scope**: xlrd3 will safely and reliably ignore any of these if present in the file:
+* Charts, Macros, Pictures, any other embedded object. WARNING: currently this includes embedded worksheets.
+* VBA modules
+* Formulas (results of formula calculations are extracted, of course).
+* Comments
+* Hyperlinks
+* Autofilters, advanced filters, pivot tables, conditional formatting, data validation
+* Handling password-protected (encrypted) files.
+**Installation**:`$pip install xlrd3`
+**Quick start**:
+```python
+import xlrd3 as xlrd
+book = xlrd.open_workbook("myfile.xls")
+print("The number of worksheets is {0}".format(book.nsheets))
+print("Worksheet name(s): {0}".format(book.sheet_names()))
+sh = book.sheet_by_index(0)
+print("{0} {1} {2}".format(sh.name, sh.nrows, sh.ncols))
+print("Cell D30 is {0}".format(sh.cell_value(rowx=29, colx=3)))
+for rx in range(sh.nrows):
+ print(sh.row(rx))
+```
+**Another quick start**: This will show the first, second and last rows of each sheet in each file:
+ python PYDIR/scripts/runxlrd.py 3rows *blah*.xls
+**Acknowledgements**:
+* This package started life as a translation from C into Python of parts of a utility called "xlreader" developed by David Giffin. "This product includes software developed by David Giffin <david@giffin.org>."
+* OpenOffice.org has truly excellent documentation of the Microsoft Excel file formats and Compound Document file format, authored by Daniel Rentz. See http://sc.openoffice.org
+* U+5F20 U+654F: over a decade of inspiration, support, and interesting decoding opportunities.
+* Ksenia Marasanova: sample Macintosh and non-Latin1 files, alpha testing
+* Backporting to Python 2.1 was partially funded by Journyx - provider of timesheet and project accounting solutions (http://journyx.com/).
+* Provision of formatting information in version 0.6.1 was funded by Simplistix Ltd (http://www.simplistix.co.uk/)
+
+%prep
+%autosetup -n xlrd3-1.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-xlrd3 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.0-1
+- Package Spec generated