summaryrefslogtreecommitdiff
path: root/python-xmindparser.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 22:06:56 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 22:06:56 +0000
commit4fea57fc369987bd78a5d774d629bed435ce7008 (patch)
tree0653d6a719cfeaa64ff02884a3295ce3527ecce6 /python-xmindparser.spec
parent5395b93066c259d2da2d86263d556c74779127ee (diff)
automatic import of python-xmindparser
Diffstat (limited to 'python-xmindparser.spec')
-rw-r--r--python-xmindparser.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-xmindparser.spec b/python-xmindparser.spec
new file mode 100644
index 0000000..9277b3c
--- /dev/null
+++ b/python-xmindparser.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-xmindparser
+Version: 1.0.9
+Release: 1
+Summary: Convert xmind to programmable data types, support xmind pro and xmind zen file types.
+License: MIT License
+URL: https://github.com/tobyqin/xmindparser
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2d/c6/1f2a60c2f95cedf347699745fa3e483cbbc9b048a5a5f74d3a70e6edec73/xmindparser-1.0.9.tar.gz
+BuildArch: noarch
+
+
+%description
+xmindparser is a tool to help you convert xmind file to programmable data type, e.g. json, xml.
+Detail usage: https://github.com/tobyqin/xmindparser
+
+%package -n python3-xmindparser
+Summary: Convert xmind to programmable data types, support xmind pro and xmind zen file types.
+Provides: python-xmindparser
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-xmindparser
+xmindparser is a tool to help you convert xmind file to programmable data type, e.g. json, xml.
+Detail usage: https://github.com/tobyqin/xmindparser
+
+%package help
+Summary: Development documents and examples for xmindparser
+Provides: python3-xmindparser-doc
+%description help
+xmindparser is a tool to help you convert xmind file to programmable data type, e.g. json, xml.
+Detail usage: https://github.com/tobyqin/xmindparser
+
+%prep
+%autosetup -n xmindparser-1.0.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-xmindparser -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.9-1
+- Package Spec generated