summaryrefslogtreecommitdiff
path: root/python-xunitmerge.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 16:15:36 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 16:15:36 +0000
commit43086ac705bd46031ce8c1b83cdf96245bd39130 (patch)
tree2d11df6d1c041d4209d0307551e0f2519f6b480f /python-xunitmerge.spec
parent0332d46b1adf9a230dbcb1c74549ad26e14c402e (diff)
automatic import of python-xunitmerge
Diffstat (limited to 'python-xunitmerge.spec')
-rw-r--r--python-xunitmerge.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-xunitmerge.spec b/python-xunitmerge.spec
new file mode 100644
index 0000000..751a9dc
--- /dev/null
+++ b/python-xunitmerge.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-xunitmerge
+Version: 1.0.4
+Release: 1
+Summary: Utility for merging multiple XUnit xml reports into a single xml report.
+License: MIT
+URL: https://github.com/miki725/xunitmerge
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2f/92/4abb78646828ac0a9d552b0159ea017ba5ae8f738025bcbab5bf9210042c/xunitmerge-1.0.4.tar.gz
+BuildArch: noarch
+
+
+%description
+Utility for merging multiple XUnit xml reports into a single xml report.
+The primary purpose of this package is to be able to merge XUnit reports
+generated by nosetests (e.g. ``nosetests --with-xunit``). This is especially
+useful when nosetests needs to be run multiple times for different parts of
+a project and then all reports need to be merged to a single report
+(similar to what coverage combine does with multiple coverage reports).
+
+%package -n python3-xunitmerge
+Summary: Utility for merging multiple XUnit xml reports into a single xml report.
+Provides: python-xunitmerge
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-xunitmerge
+Utility for merging multiple XUnit xml reports into a single xml report.
+The primary purpose of this package is to be able to merge XUnit reports
+generated by nosetests (e.g. ``nosetests --with-xunit``). This is especially
+useful when nosetests needs to be run multiple times for different parts of
+a project and then all reports need to be merged to a single report
+(similar to what coverage combine does with multiple coverage reports).
+
+%package help
+Summary: Development documents and examples for xunitmerge
+Provides: python3-xunitmerge-doc
+%description help
+Utility for merging multiple XUnit xml reports into a single xml report.
+The primary purpose of this package is to be able to merge XUnit reports
+generated by nosetests (e.g. ``nosetests --with-xunit``). This is especially
+useful when nosetests needs to be run multiple times for different parts of
+a project and then all reports need to be merged to a single report
+(similar to what coverage combine does with multiple coverage reports).
+
+%prep
+%autosetup -n xunitmerge-1.0.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-xunitmerge -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.4-1
+- Package Spec generated