summaryrefslogtreecommitdiff
path: root/python-xxhash.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 10:21:08 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 10:21:08 +0000
commitfe5ca1c42c9f9a9f88fbf16d8e4c991df2c7fb9a (patch)
treefb24c7348b57201e69c291f3b9b05a9487c0da42 /python-xxhash.spec
parentb9e022771dc66bad450adf275866e4e104f8c57d (diff)
automatic import of python-xxhash
Diffstat (limited to 'python-xxhash.spec')
-rw-r--r--python-xxhash.spec77
1 files changed, 77 insertions, 0 deletions
diff --git a/python-xxhash.spec b/python-xxhash.spec
new file mode 100644
index 0000000..d5fb80c
--- /dev/null
+++ b/python-xxhash.spec
@@ -0,0 +1,77 @@
+%global _empty_manifest_terminate_build 0
+Name: python-xxhash
+Version: 3.2.0
+Release: 1
+Summary: Python binding for xxHash
+License: BSD
+URL: https://github.com/ifduyue/python-xxhash
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/24/90/666a4d4d96a93ddaaaa0142ef8c1bd20f7135a7f1114a894f4d6efac16c5/xxhash-3.2.0.tar.gz
+
+
+%description
+xxhash is a Python binding for the xxHash_ library by `Yann Collet`__.
+__ Cyan4973_
+
+%package -n python3-xxhash
+Summary: Python binding for xxHash
+Provides: python-xxhash
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-xxhash
+xxhash is a Python binding for the xxHash_ library by `Yann Collet`__.
+__ Cyan4973_
+
+%package help
+Summary: Development documents and examples for xxhash
+Provides: python3-xxhash-doc
+%description help
+xxhash is a Python binding for the xxHash_ library by `Yann Collet`__.
+__ Cyan4973_
+
+%prep
+%autosetup -n xxhash-3.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-xxhash -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.2.0-1
+- Package Spec generated