summaryrefslogtreecommitdiff
path: root/python-yahoo-fin.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 05:14:46 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 05:14:46 +0000
commitc0d7d45bda8e4ad49694469a02a1e0f3b8b7c582 (patch)
tree39931378d508dc244943a34c49f10eab6a8f3823 /python-yahoo-fin.spec
parentf4f94b2a59bf5ea076fb9df8aac3d662f1922631 (diff)
automatic import of python-yahoo-fin
Diffstat (limited to 'python-yahoo-fin.spec')
-rw-r--r--python-yahoo-fin.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-yahoo-fin.spec b/python-yahoo-fin.spec
new file mode 100644
index 0000000..d6120d4
--- /dev/null
+++ b/python-yahoo-fin.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-yahoo-fin
+Version: 0.8.9.1
+Release: 1
+Summary: Download historical stock prices (daily / weekly / monthly), realtime-prices, fundamentals data, income statements, cash flows, analyst info, current cryptocurrency prices, option chains, earnings history, and more with yahoo_fin.
+License: MIT
+URL: http://theautomatic.net/yahoo_fin-documentation/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/da/d2/0ac82f1b28492ad49664f630ed8157938d5be808428c7cef81cbd018ae41/yahoo_fin-0.8.9.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests-html
+Requires: python3-feedparser
+Requires: python3-requests
+Requires: python3-pandas
+
+%description
+
+
+%package -n python3-yahoo-fin
+Summary: Download historical stock prices (daily / weekly / monthly), realtime-prices, fundamentals data, income statements, cash flows, analyst info, current cryptocurrency prices, option chains, earnings history, and more with yahoo_fin.
+Provides: python-yahoo-fin
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-yahoo-fin
+
+
+%package help
+Summary: Development documents and examples for yahoo-fin
+Provides: python3-yahoo-fin-doc
+%description help
+
+
+%prep
+%autosetup -n yahoo-fin-0.8.9.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-yahoo-fin -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.9.1-1
+- Package Spec generated