summaryrefslogtreecommitdiff
path: root/python-yarom.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-yarom.spec')
-rw-r--r--python-yarom.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-yarom.spec b/python-yarom.spec
new file mode 100644
index 0000000..29a67bc
--- /dev/null
+++ b/python-yarom.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-YAROM
+Version: 0.12.0
+Release: 1
+Summary: Yet Another RDF-Object Mapper
+License: BSD 3-clause
+URL: http://yarom.readthedocs.org/en/latest/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/80/88/848b338971e821a66419317449ef1e3211484b6c7e0a18413fa8cac97653/YAROM-0.12.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Yet Another RDF-Object Mapper (YAROM) is a Python library useful for building
+Create-Read-Update-Delete (CRUD) tools and applications using Python objects
+and RDF. YAROM grew out of the `PyOpenWorm <https://github.com/openworm/PyOpenWorm>`_
+project.
+
+%package -n python3-YAROM
+Summary: Yet Another RDF-Object Mapper
+Provides: python-YAROM
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-YAROM
+Yet Another RDF-Object Mapper (YAROM) is a Python library useful for building
+Create-Read-Update-Delete (CRUD) tools and applications using Python objects
+and RDF. YAROM grew out of the `PyOpenWorm <https://github.com/openworm/PyOpenWorm>`_
+project.
+
+%package help
+Summary: Development documents and examples for YAROM
+Provides: python3-YAROM-doc
+%description help
+Yet Another RDF-Object Mapper (YAROM) is a Python library useful for building
+Create-Read-Update-Delete (CRUD) tools and applications using Python objects
+and RDF. YAROM grew out of the `PyOpenWorm <https://github.com/openworm/PyOpenWorm>`_
+project.
+
+%prep
+%autosetup -n YAROM-0.12.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-YAROM -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.12.0-1
+- Package Spec generated