summaryrefslogtreecommitdiff
path: root/python-youtube-dl2.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 16:48:06 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 16:48:06 +0000
commitcad2345710ba326fb9d83927cf9b7b0beb0e8cdd (patch)
tree5a3f486bc99ed2df12c4ec17ece981f10b29f646 /python-youtube-dl2.spec
parent858026ae53f9a129c0e816e28e5cd41ea6ba5466 (diff)
automatic import of python-youtube-dl2
Diffstat (limited to 'python-youtube-dl2.spec')
-rw-r--r--python-youtube-dl2.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-youtube-dl2.spec b/python-youtube-dl2.spec
new file mode 100644
index 0000000..ee0b225
--- /dev/null
+++ b/python-youtube-dl2.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-youtube-dl2
+Version: 2.0
+Release: 1
+Summary: YouTube video downloader
+License: Unlicense
+URL: https://github.com/ytdl-org/youtube-dl
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b8/58/8fe4fff82e8e1c88b0c374005e6421d0feb36ce6c7e699e4329eaf963772/youtube_dl2-2.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Command-line program to download videos from YouTube.com and other video sites
+
+%package -n python3-youtube-dl2
+Summary: YouTube video downloader
+Provides: python-youtube-dl2
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-youtube-dl2
+Command-line program to download videos from YouTube.com and other video sites
+
+%package help
+Summary: Development documents and examples for youtube-dl2
+Provides: python3-youtube-dl2-doc
+%description help
+Command-line program to download videos from YouTube.com and other video sites
+
+%prep
+%autosetup -n youtube-dl2-2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-youtube-dl2 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0-1
+- Package Spec generated