summaryrefslogtreecommitdiff
path: root/python-django-pyscss.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-django-pyscss.spec')
-rw-r--r--python-django-pyscss.spec77
1 files changed, 77 insertions, 0 deletions
diff --git a/python-django-pyscss.spec b/python-django-pyscss.spec
new file mode 100644
index 0000000..fcdd59f
--- /dev/null
+++ b/python-django-pyscss.spec
@@ -0,0 +1,77 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-pyscss
+Version: 2.0.2
+Release: 1
+Summary: Makes it easier to use PySCSS in Django.
+License: UNKNOWN
+URL: https://github.com/fusionbox/django-pyscss
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4b/7f/d771802305184aac6010826f60a0b2ecaa3f57d19ab0e405f0c8db07e809/django-pyscss-2.0.2.tar.gz
+BuildArch: noarch
+
+
+%description
+A collection of tools for making it easier to use pyScss within Django.
+ This version only supports pyScss 1.3.4 and greater. For pyScss 1.2 support,
+ you can use the 1.x series of django-pyscss.
+
+%package -n python3-django-pyscss
+Summary: Makes it easier to use PySCSS in Django.
+Provides: python-django-pyscss
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-django-pyscss
+A collection of tools for making it easier to use pyScss within Django.
+ This version only supports pyScss 1.3.4 and greater. For pyScss 1.2 support,
+ you can use the 1.x series of django-pyscss.
+
+%package help
+Summary: Development documents and examples for django-pyscss
+Provides: python3-django-pyscss-doc
+%description help
+A collection of tools for making it easier to use pyScss within Django.
+ This version only supports pyScss 1.3.4 and greater. For pyScss 1.2 support,
+ you can use the 1.x series of django-pyscss.
+
+%prep
+%autosetup -n django-pyscss-2.0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-pyscss -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.2-1
+- Package Spec generated