summaryrefslogtreecommitdiff
path: root/python-fastpurge.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-fastpurge.spec')
-rw-r--r--python-fastpurge.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/python-fastpurge.spec b/python-fastpurge.spec
new file mode 100644
index 0000000..cb87b02
--- /dev/null
+++ b/python-fastpurge.spec
@@ -0,0 +1,85 @@
+%global _empty_manifest_terminate_build 0
+Name: python-fastpurge
+Version: 1.0.4
+Release: 1
+Summary: A client for the Akamai Fast Purge API
+License: GNU General Public License
+URL: https://github.com/release-engineering/python-fastpurge
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8e/81/4572f998a82cb7187e59ab746c93c9f6863a294ab3726ea8bed655bf5fb3/fastpurge-1.0.4.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-more-executors
+Requires: python3-six
+Requires: python3-edgegrid-python
+Requires: python3-monotonic
+
+%description
+Install the `fastpurge` package from PyPI.
+```
+pip install fastpurge
+```
+
+%package -n python3-fastpurge
+Summary: A client for the Akamai Fast Purge API
+Provides: python-fastpurge
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-fastpurge
+Install the `fastpurge` package from PyPI.
+```
+pip install fastpurge
+```
+
+%package help
+Summary: Development documents and examples for fastpurge
+Provides: python3-fastpurge-doc
+%description help
+Install the `fastpurge` package from PyPI.
+```
+pip install fastpurge
+```
+
+%prep
+%autosetup -n fastpurge-1.0.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-fastpurge -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.4-1
+- Package Spec generated