summaryrefslogtreecommitdiff
path: root/python-gabbi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-gabbi.spec')
-rw-r--r--python-gabbi.spec122
1 files changed, 122 insertions, 0 deletions
diff --git a/python-gabbi.spec b/python-gabbi.spec
new file mode 100644
index 0000000..074fdb9
--- /dev/null
+++ b/python-gabbi.spec
@@ -0,0 +1,122 @@
+%global _empty_manifest_terminate_build 0
+Name: python-gabbi
+Version: 2.8.0
+Release: 1
+Summary: Declarative HTTP testing library
+License: Apache-2
+URL: https://github.com/cdent/gabbi
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9e/3f/665b2be5df3428f061724c4e9226bb0c4add885a1c9de4106f22dcbc28b0/gabbi-2.8.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-pbr
+Requires: python3-pytest
+Requires: python3-six
+Requires: python3-PyYAML
+Requires: python3-urllib3
+Requires: python3-certifi
+Requires: python3-jsonpath-rw-ext
+Requires: python3-wsgi-intercept
+Requires: python3-colorama
+
+%description
+`Release Notes`_
+Gabbi is a tool for running HTTP tests where requests and responses
+are represented in a declarative YAML-based form. The simplest test
+looks like this::
+ tests:
+ - name: A test
+ GET: /api/resources/id
+See the docs_ for more details on the many features and formats for
+setting request headers and bodies and evaluating responses.
+Gabbi is tested with Python 3.6, 3.7, 3.8, 3.9, 3.10 and pypy3.
+Tests can be run using `unittest`_ style test runners, `pytest`_
+or from the command line with a `gabbi-run`_ script.
+There is a `gabbi-demo`_ repository which provides a tutorial via
+its commit history. The demo builds a simple API using gabbi to
+facilitate test driven development.
+
+%package -n python3-gabbi
+Summary: Declarative HTTP testing library
+Provides: python-gabbi
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-gabbi
+`Release Notes`_
+Gabbi is a tool for running HTTP tests where requests and responses
+are represented in a declarative YAML-based form. The simplest test
+looks like this::
+ tests:
+ - name: A test
+ GET: /api/resources/id
+See the docs_ for more details on the many features and formats for
+setting request headers and bodies and evaluating responses.
+Gabbi is tested with Python 3.6, 3.7, 3.8, 3.9, 3.10 and pypy3.
+Tests can be run using `unittest`_ style test runners, `pytest`_
+or from the command line with a `gabbi-run`_ script.
+There is a `gabbi-demo`_ repository which provides a tutorial via
+its commit history. The demo builds a simple API using gabbi to
+facilitate test driven development.
+
+%package help
+Summary: Development documents and examples for gabbi
+Provides: python3-gabbi-doc
+%description help
+`Release Notes`_
+Gabbi is a tool for running HTTP tests where requests and responses
+are represented in a declarative YAML-based form. The simplest test
+looks like this::
+ tests:
+ - name: A test
+ GET: /api/resources/id
+See the docs_ for more details on the many features and formats for
+setting request headers and bodies and evaluating responses.
+Gabbi is tested with Python 3.6, 3.7, 3.8, 3.9, 3.10 and pypy3.
+Tests can be run using `unittest`_ style test runners, `pytest`_
+or from the command line with a `gabbi-run`_ script.
+There is a `gabbi-demo`_ repository which provides a tutorial via
+its commit history. The demo builds a simple API using gabbi to
+facilitate test driven development.
+
+%prep
+%autosetup -n gabbi-2.8.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-gabbi -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Feb 24 2023 Python_Bot <Python_Bot@openeuler.org> - 2.8.0-1
+- Package Spec generated