summaryrefslogtreecommitdiff
path: root/python-healpy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-healpy.spec')
-rw-r--r--python-healpy.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-healpy.spec b/python-healpy.spec
new file mode 100644
index 0000000..281d6d7
--- /dev/null
+++ b/python-healpy.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-healpy
+Version: 1.16.2
+Release: 1
+Summary: Healpix tools package for Python
+License: GPLv2
+URL: http://github.com/healpy
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/76/57/add5f1feb33ca3ef50fedb99a356998caaab9b014adb48fd36dcf4847dcd/healpy-1.16.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-matplotlib
+Requires: python3-numpy
+Requires: python3-astropy
+Requires: python3-scipy
+
+%description
+
+
+%package -n python3-healpy
+Summary: Healpix tools package for Python
+Provides: python-healpy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-healpy
+
+
+%package help
+Summary: Development documents and examples for healpy
+Provides: python3-healpy-doc
+%description help
+
+
+%prep
+%autosetup -n healpy-1.16.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-healpy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sat Feb 25 2023 Python_Bot <Python_Bot@openeuler.org> - 1.16.2-1
+- Package Spec generated