summaryrefslogtreecommitdiff
path: root/python-osmium.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-osmium.spec')
-rw-r--r--python-osmium.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-osmium.spec b/python-osmium.spec
new file mode 100644
index 0000000..bbb3c5a
--- /dev/null
+++ b/python-osmium.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-osmium
+Version: 3.6.0
+Release: 1
+Summary: Python bindings for libosmium, the data processing library for OSM data
+License: BSD
+URL: https://osmcode.org/pyosmium
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e3/33/1b528f9fa18a1208a3bc948f72042c7e697a956a41965a225f30439002bf/osmium-3.6.0.tar.gz
+
+Requires: python3-requests
+
+%description
+
+
+%package -n python3-osmium
+Summary: Python bindings for libosmium, the data processing library for OSM data
+Provides: python-osmium
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-osmium
+
+
+%package help
+Summary: Development documents and examples for osmium
+Provides: python3-osmium-doc
+%description help
+
+
+%prep
+%autosetup -n osmium-3.6.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-osmium -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sat Feb 25 2023 Python_Bot <Python_Bot@openeuler.org> - 3.6.0-1
+- Package Spec generated