From e6d1cf850bcf8c07f42a6e4b9c55cebf316154ed Mon Sep 17 00:00:00 2001
From: CoprDistGit <infra@openeuler.org>
Date: Fri, 10 Mar 2023 14:16:03 +0000
Subject: automatic import of rubygem-hoe

---
 rubygem-hoe.spec | 94 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 94 insertions(+)
 create mode 100644 rubygem-hoe.spec

(limited to 'rubygem-hoe.spec')

diff --git a/rubygem-hoe.spec b/rubygem-hoe.spec
new file mode 100644
index 0000000..8fb4f27
--- /dev/null
+++ b/rubygem-hoe.spec
@@ -0,0 +1,94 @@
+%global _empty_manifest_terminate_build 0
+%global gem_name hoe
+Name:		rubygem-hoe
+Version:	4.0.2
+Release:	1
+Summary:	Hoe is a rake/rubygems helper for project Rakefiles
+License:	MIT
+URL:		http://www.zenspider.com/projects/hoe.html
+Source0:	https://rubygems.org/gems/hoe-4.0.2.gem
+BuildArch:	noarch
+
+Requires:	rubygem-rake
+BuildRequires:	ruby
+BuildRequires:	ruby-devel
+BuildRequires:	rubygems
+BuildRequires:	rubygems-devel
+BuildRequires:	rsync
+Provides:	rubygem-hoe
+
+%description
+Hoe is a rake/rubygems helper for project Rakefiles. It helps you
+manage, maintain, and release your project and includes a dynamic
+plug-in system allowing for easy extensibility. Hoe ships with
+plug-ins for all your usual project tasks including rdoc generation,
+testing, packaging, deployment, and announcement.
+
+See class rdoc for help. Hint: `ri Hoe` or any of the plugins listed
+below.
+
+For extra goodness, see: http://docs.seattlerb.org/hoe/Hoe.pdf
+
+%package help
+Summary:	Development documents and examples for hoe
+Provides:	rubygem-hoe-doc
+BuildArch: noarch
+
+%description help
+Hoe is a rake/rubygems helper for project Rakefiles. It helps you
+manage, maintain, and release your project and includes a dynamic
+plug-in system allowing for easy extensibility. Hoe ships with
+plug-ins for all your usual project tasks including rdoc generation,
+testing, packaging, deployment, and announcement.
+
+See class rdoc for help. Hint: `ri Hoe` or any of the plugins listed
+below.
+
+For extra goodness, see: http://docs.seattlerb.org/hoe/Hoe.pdf
+
+%prep
+%autosetup -n hoe-4.0.2
+gem spec %{SOURCE0} -l --ruby > hoe.gemspec
+
+%build
+gem build hoe.gemspec
+%gem_install
+
+%install
+mkdir -p %{buildroot}%{gem_dir}
+cp -a .%{gem_dir}/* %{buildroot}%{gem_dir}/
+rsync -a --exclude=".*" .%{gem_dir}/* %{buildroot}%{gem_dir}/
+if [ -d .%{_bindir} ]; then
+	mkdir -p %{buildroot}%{_bindir}
+	cp -a .%{_bindir}/* %{buildroot}%{_bindir}/
+fi
+if [ -d ext ]; then
+	mkdir -p %{buildroot}%{gem_extdir_mri}/%{gem_name}
+	if [ -d .%{gem_extdir_mri}/%{gem_name} ]; then
+		cp -a .%{gem_extdir_mri}/%{gem_name}/*.so %{buildroot}%{gem_extdir_mri}/%{gem_name}
+	else
+		cp -a .%{gem_extdir_mri}/*.so %{buildroot}%{gem_extdir_mri}/%{gem_name}
+fi
+	cp -a .%{gem_extdir_mri}/gem.build_complete %{buildroot}%{gem_extdir_mri}/
+	rm -rf %{buildroot}%{gem_instdir}/ext/
+fi
+pushd %{buildroot}
+touch filelist.lst
+if [ -d %{buildroot}%{_bindir} ]; then
+	find .%{_bindir} -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+
+%files -n rubygem-hoe -f filelist.lst
+%dir %{gem_instdir}
+%{gem_instdir}/*
+%exclude %{gem_cache}
+%{gem_spec}
+
+%files help
+%{gem_docdir}/*
+
+%changelog
+* Fri Mar 10 2023 Ruby_Bot <Ruby_Bot@openeuler.org>
+- Package Spec generated
-- 
cgit v1.2.3