From 8694a25f3e3cf53d09d65b8969b6355fa3dab9d2 Mon Sep 17 00:00:00 2001
From: CoprDistGit <infra@openeuler.org>
Date: Fri, 10 Mar 2023 15:53:33 +0000
Subject: automatic import of rubygem-ox

---
 rubygem-ox.spec | 87 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 87 insertions(+)
 create mode 100644 rubygem-ox.spec

(limited to 'rubygem-ox.spec')

diff --git a/rubygem-ox.spec b/rubygem-ox.spec
new file mode 100644
index 0000000..3189a88
--- /dev/null
+++ b/rubygem-ox.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+%global gem_name ox
+Name:		rubygem-ox
+Version:	2.14.14
+Release:	1
+Summary:	A fast XML parser and object serializer.
+License:	MIT
+URL:		http://www.ohler.com/ox
+Source0:	https://rubygems.org/gems/ox-2.14.14.gem
+
+BuildRequires:	ruby
+BuildRequires:	ruby-devel
+BuildRequires:	rubygems
+BuildRequires:	rubygems-devel
+BuildRequires:	rsync
+BuildRequires:	gcc
+BuildRequires:	gdb
+Provides:	rubygem-ox
+
+%description
+A fast XML parser and object serializer that uses only standard C lib.
+
+Optimized XML (Ox), as the name implies was written to provide speed optimized
+XML handling. It was designed to be an alternative to Nokogiri and other Ruby
+XML parsers for generic XML parsing and as an alternative to Marshal for Object
+serialization. 
+
+%package help
+Summary:	Development documents and examples for ox
+Provides:	rubygem-ox-doc
+BuildArch: noarch
+
+%description help
+A fast XML parser and object serializer that uses only standard C lib.
+
+Optimized XML (Ox), as the name implies was written to provide speed optimized
+XML handling. It was designed to be an alternative to Nokogiri and other Ruby
+XML parsers for generic XML parsing and as an alternative to Marshal for Object
+serialization. 
+
+%prep
+%autosetup -n ox-2.14.14
+gem spec %{SOURCE0} -l --ruby > ox.gemspec
+
+%build
+gem build ox.gemspec
+%gem_install
+
+%install
+mkdir -p %{buildroot}%{gem_dir}
+cp -a .%{gem_dir}/* %{buildroot}%{gem_dir}/
+rsync -a --exclude=".*" .%{gem_dir}/* %{buildroot}%{gem_dir}/
+if [ -d .%{_bindir} ]; then
+	mkdir -p %{buildroot}%{_bindir}
+	cp -a .%{_bindir}/* %{buildroot}%{_bindir}/
+fi
+if [ -d ext ]; then
+	mkdir -p %{buildroot}%{gem_extdir_mri}/%{gem_name}
+	if [ -d .%{gem_extdir_mri}/%{gem_name} ]; then
+		cp -a .%{gem_extdir_mri}/%{gem_name}/*.so %{buildroot}%{gem_extdir_mri}/%{gem_name}
+	else
+		cp -a .%{gem_extdir_mri}/*.so %{buildroot}%{gem_extdir_mri}/%{gem_name}
+fi
+	cp -a .%{gem_extdir_mri}/gem.build_complete %{buildroot}%{gem_extdir_mri}/
+	rm -rf %{buildroot}%{gem_instdir}/ext/
+fi
+pushd %{buildroot}
+touch filelist.lst
+if [ -d %{buildroot}%{_bindir} ]; then
+	find .%{_bindir} -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+
+%files -n rubygem-ox -f filelist.lst
+%dir %{gem_instdir}
+%{gem_instdir}/*
+%{gem_extdir_mri}
+%exclude %{gem_cache}
+%{gem_spec}
+
+%files help
+%{gem_docdir}/*
+
+%changelog
+* Fri Mar 10 2023 Ruby_Bot <Ruby_Bot@openeuler.org>
+- Package Spec generated
-- 
cgit v1.2.3