From 47e3520da2961f34943032e68242a3110aec4501 Mon Sep 17 00:00:00 2001
From: CoprDistGit <infra@openeuler.org>
Date: Fri, 10 Mar 2023 14:56:48 +0000
Subject: automatic import of rubygem-sup

---
 rubygem-sup.spec | 103 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 103 insertions(+)
 create mode 100644 rubygem-sup.spec

(limited to 'rubygem-sup.spec')

diff --git a/rubygem-sup.spec b/rubygem-sup.spec
new file mode 100644
index 0000000..cc3d9df
--- /dev/null
+++ b/rubygem-sup.spec
@@ -0,0 +1,103 @@
+%global _empty_manifest_terminate_build 0
+%global gem_name sup
+Name:		rubygem-sup
+Version:	1.1
+Release:	1
+Summary:	A console-based email client with the best features of GMail, mutt and Emacs
+License:	GPL-2.0
+URL:		https://sup-heliotrope.github.io/
+Source0:	https://rubygems.org/gems/sup-1.1.gem
+
+Requires:	rubygem-chronic
+Requires:	rubygem-highline
+Requires:	rubygem-locale
+Requires:	rubygem-lockfile
+Requires:	rubygem-mime-types
+Requires:	rubygem-ncursesw
+Requires:	rubygem-optimist
+Requires:	rubygem-rmail
+Requires:	rubygem-unicode
+Requires:	rubygem-unicode-display_width
+BuildRequires:	ruby
+BuildRequires:	ruby-devel
+BuildRequires:	rubygems
+BuildRequires:	rubygems-devel
+BuildRequires:	rsync
+BuildRequires:	gcc
+BuildRequires:	gdb
+Provides:	rubygem-sup
+
+%description
+    Sup is a console-based email client for people with a lot of email.
+
+    * GMail-like thread-centered archiving, tagging and muting
+    * Handling mail from multiple mbox and Maildir sources
+    * Blazing fast full-text search with a rich query language
+    * Multiple accounts - pick the right one when sending mail
+    * Ruby-programmable hooks
+    * Automatically tracking recent contacts
+
+
+%package help
+Summary:	Development documents and examples for sup
+Provides:	rubygem-sup-doc
+BuildArch: noarch
+
+%description help
+    Sup is a console-based email client for people with a lot of email.
+
+    * GMail-like thread-centered archiving, tagging and muting
+    * Handling mail from multiple mbox and Maildir sources
+    * Blazing fast full-text search with a rich query language
+    * Multiple accounts - pick the right one when sending mail
+    * Ruby-programmable hooks
+    * Automatically tracking recent contacts
+
+
+%prep
+%autosetup -n sup-1.1
+gem spec %{SOURCE0} -l --ruby > sup.gemspec
+
+%build
+gem build sup.gemspec
+%gem_install
+
+%install
+mkdir -p %{buildroot}%{gem_dir}
+cp -a .%{gem_dir}/* %{buildroot}%{gem_dir}/
+rsync -a --exclude=".*" .%{gem_dir}/* %{buildroot}%{gem_dir}/
+if [ -d .%{_bindir} ]; then
+	mkdir -p %{buildroot}%{_bindir}
+	cp -a .%{_bindir}/* %{buildroot}%{_bindir}/
+fi
+if [ -d ext ]; then
+	mkdir -p %{buildroot}%{gem_extdir_mri}/%{gem_name}
+	if [ -d .%{gem_extdir_mri}/%{gem_name} ]; then
+		cp -a .%{gem_extdir_mri}/%{gem_name}/*.so %{buildroot}%{gem_extdir_mri}/%{gem_name}
+	else
+		cp -a .%{gem_extdir_mri}/*.so %{buildroot}%{gem_extdir_mri}/%{gem_name}
+fi
+	cp -a .%{gem_extdir_mri}/gem.build_complete %{buildroot}%{gem_extdir_mri}/
+	rm -rf %{buildroot}%{gem_instdir}/ext/
+fi
+pushd %{buildroot}
+touch filelist.lst
+if [ -d %{buildroot}%{_bindir} ]; then
+	find .%{_bindir} -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+
+%files -n rubygem-sup -f filelist.lst
+%dir %{gem_instdir}
+%{gem_instdir}/*
+%{gem_extdir_mri}
+%exclude %{gem_cache}
+%{gem_spec}
+
+%files help
+%{gem_docdir}/*
+
+%changelog
+* Fri Mar 10 2023 Ruby_Bot <Ruby_Bot@openeuler.org>
+- Package Spec generated
-- 
cgit v1.2.3