summaryrefslogtreecommitdiff
path: root/dpdk.spec
diff options
context:
space:
mode:
Diffstat (limited to 'dpdk.spec')
-rw-r--r--dpdk.spec26
1 files changed, 18 insertions, 8 deletions
diff --git a/dpdk.spec b/dpdk.spec
index e0dd0c6..9c01ff9 100644
--- a/dpdk.spec
+++ b/dpdk.spec
@@ -9,7 +9,7 @@
%global _vpath_builddir %{_vendor}-%{_target_os}-build
Name: dpdk
-Version: 23.11.3
+Version: 24.11.1
Release: 1%{?dist}
Epoch: 3
URL: http://dpdk.org
@@ -25,7 +25,8 @@ Summary: Set of libraries and drivers for fast packet processing
# Pakcage are BSD licensed. The only files that aren't licensed via BSD is the
# kni kernel module which is dual LGPLv2/BSD, and thats not built for fedora.
#
-License: BSD and LGPLv2 and GPLv2
+# Automatically converted from old format: BSD and LGPLv2 and GPLv2 - review is highly recommended.
+License: LicenseRef-Callaway-BSD AND LicenseRef-Callaway-LGPLv2 AND GPL-2.0-only
#
# The DPDK is designed to optimize througput of network traffic using, among
@@ -38,13 +39,13 @@ BuildRequires: gcc
BuildRequires: kernel-headers, libpcap-devel, doxygen, /usr/bin/sphinx-build, zlib-devel
BuildRequires: numactl-devel
BuildRequires: rdma-core-devel
+BuildRequires: openssl-devel
+%ifnarch %{ix86}
+BuildRequires: libbpf-devel
+%endif
BuildRequires: libfdt-devel
BuildRequires: libatomic
-%if 0%{?fedora} || 0%{?rhel} > 7 || 0%{?openEuler}
-BuildRequires: libbpf-devel
-BuildRequires: openssl-devel
BuildRequires: libarchive-devel
-%endif
%description
The Data Plane Development Kit is a set of libraries and drivers for
@@ -124,7 +125,7 @@ end
CFLAGS="$(echo %{optflags} -fcommon)" \
%meson --includedir=include/dpdk \
-Ddrivers_install_subdir=dpdk-pmds \
- -Denable_docs=false \
+ -Denable_docs=true \
-Dmachine=generic \
%if %{with examples}
-Dexamples=all \
@@ -140,6 +141,12 @@ CFLAGS="$(echo %{optflags} -fcommon)" \
%install
%meson_install
+# Taken from debian/rules
+rm -f %{buildroot}%{docdir}/html/.buildinfo
+rm -f %{buildroot}%{docdir}/html/objects.inv
+rm -rf %{buildroot}%{docdir}/html/.doctrees
+find %{buildroot}%{_mandir}/ -type f -a ! -iname "*rte_*" -delete
+
%files
# BSD
%{_bindir}/dpdk-testpmd
@@ -157,6 +164,7 @@ CFLAGS="$(echo %{optflags} -fcommon)" \
#BSD
%{incdir}/
%{sdkdir}
+%{_mandir}
%ghost %{sdkdir}/mk/exec-env/bsdapp
%ghost %{sdkdir}/mk/exec-env/linuxapp
%if %{with tools}
@@ -179,9 +187,11 @@ CFLAGS="$(echo %{optflags} -fcommon)" \
%if %{with tools}
%files tools
+%ifnarch %{ix86}
%{_bindir}/dpdk-dumpcap
-%{_bindir}/dpdk-graph
%{_bindir}/dpdk-pdump
+%endif
+%{_bindir}/dpdk-graph
%{_bindir}/dpdk-test
%{_bindir}/dpdk-test-*
%{_bindir}/dpdk-*.py