summaryrefslogtreecommitdiff
path: root/python-aiofiles.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-aiofiles.spec')
-rw-r--r--python-aiofiles.spec122
1 files changed, 40 insertions, 82 deletions
diff --git a/python-aiofiles.spec b/python-aiofiles.spec
index 4d01a12..8d9d06c 100644
--- a/python-aiofiles.spec
+++ b/python-aiofiles.spec
@@ -1,120 +1,78 @@
%global _empty_manifest_terminate_build 0
Name: python-aiofiles
-Version: 23.1.0
+Version: 24.1.0
Release: 1
Summary: File support for asyncio.
License: Apache-2.0
URL: https://github.com/Tinche/aiofiles
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/40/a0/07be94aecba162ed5147359f9883e82afd2ac13aed33678a008fc8c36f8b/aiofiles-23.1.0.tar.gz
+Source0: https://files.pythonhosted.org/packages/0b/03/a88171e277e8caa88a4c77808c20ebb04ba74cc4681bf1e9416c862de237/aiofiles-24.1.0.tar.gz
BuildArch: noarch
%description
-**aiofiles** is an Apache2 licensed library, written in Python, for handling local
+aiofiles is an Apache2 licensed library, written in Python, for handling local
disk files in asyncio applications.
-Ordinary local file IO is blocking, and cannot easily and portably made
-asynchronous. This means doing file IO may interfere with asyncio applications,
-which shouldn't block the executing thread. aiofiles helps with this by
-introducing asynchronous versions of files that support delegating operations to
-a separate thread pool.
- async with aiofiles.open('filename', mode='r') as f:
- contents = await f.read()
- print(contents)
- 'My file contents'
-Asynchronous iteration is also supported.
- async with aiofiles.open('filename') as f:
- async for line in f:
-Asynchronous interface to tempfile module.
- async with aiofiles.tempfile.TemporaryFile('wb') as f:
- await f.write(b'Hello, World!')
%package -n python3-aiofiles
Summary: File support for asyncio.
-Provides: python-aiofiles
+Provides: python-aiofiles = %{version}-%{release}
BuildRequires: python3-devel
-BuildRequires: python3-setuptools
BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-flit
+BuildRequires: python3-hatchling
+
%description -n python3-aiofiles
-**aiofiles** is an Apache2 licensed library, written in Python, for handling local
+aiofiles is an Apache2 licensed library, written in Python, for handling local
disk files in asyncio applications.
-Ordinary local file IO is blocking, and cannot easily and portably made
-asynchronous. This means doing file IO may interfere with asyncio applications,
-which shouldn't block the executing thread. aiofiles helps with this by
-introducing asynchronous versions of files that support delegating operations to
-a separate thread pool.
- async with aiofiles.open('filename', mode='r') as f:
- contents = await f.read()
- print(contents)
- 'My file contents'
-Asynchronous iteration is also supported.
- async with aiofiles.open('filename') as f:
- async for line in f:
-Asynchronous interface to tempfile module.
- async with aiofiles.tempfile.TemporaryFile('wb') as f:
- await f.write(b'Hello, World!')
%package help
Summary: Development documents and examples for aiofiles
Provides: python3-aiofiles-doc
+
%description help
-**aiofiles** is an Apache2 licensed library, written in Python, for handling local
+aiofiles is an Apache2 licensed library, written in Python, for handling local
disk files in asyncio applications.
-Ordinary local file IO is blocking, and cannot easily and portably made
-asynchronous. This means doing file IO may interfere with asyncio applications,
-which shouldn't block the executing thread. aiofiles helps with this by
-introducing asynchronous versions of files that support delegating operations to
-a separate thread pool.
- async with aiofiles.open('filename', mode='r') as f:
- contents = await f.read()
- print(contents)
- 'My file contents'
-Asynchronous iteration is also supported.
- async with aiofiles.open('filename') as f:
- async for line in f:
-Asynchronous interface to tempfile module.
- async with aiofiles.tempfile.TemporaryFile('wb') as f:
- await f.write(b'Hello, World!')
%prep
-%autosetup -n aiofiles-23.1.0
+%autosetup -n aiofiles-%{version}
%build
-%py3_build
+%pyproject_build
%install
-%py3_install
+%pyproject_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
-if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
-pushd %{buildroot}
-if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
-fi
-if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
-fi
-if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
-fi
-if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
-fi
-touch doclist.lst
-if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
-fi
-popd
-mv %{buildroot}/filelist.lst .
-mv %{buildroot}/doclist.lst .
-
-%files -n python3-aiofiles -f filelist.lst
-%dir %{python3_sitelib}/*
-
-%files help -f doclist.lst
+
+%files -n python3-aiofiles
+%{python3_sitelib}/*
+
+%files help
%{_docdir}/*
%changelog
-* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 23.1.0-1
+* Mon Jul 29 2024 guochao <guochao@kylinos.cn> - 24.1.0-1
+- Update package to version 24.1.0
+- Import os.link conditionally to fix importing on android
+- Add aiofiles.os.path.abspath and aiofiles.os.getcwd.
+
+* Mon Nov 06 2023 jiangxinyu <jiangxinyu@kylinos.cn> - 23.2.1-1
+- Update package to version 23.2.1
+
+* Mon Feb 27 2023 wubijie <wubijie@kylinos.cn> - 23.1.0-1
+- Update package to version 23.1.0
+
+* Thu Nov 10 2022 wangjunqi <wangjunqi@kylinos.cn> - 22.1.0-1
+- Update package to version 22.1.0
+
+* Fri Sep 23 2022 Qiao Jijun <qiaojijun@kylinos.cn> - 0.8.0-1
+- Update package to 0.8.0
+
+* Thu Jul 22 2021 Xu Jin <jinxu@kylinos.cn> - 0.7.0-1
+- Update package to 0.7.0
+
+* Mon Jul 06 2020 Python_Bot <Python_Bot@openeuler.org>
- Package Spec generated