From d54af6c89c11bd0a5769d908e118c8fb26e81f6d Mon Sep 17 00:00:00 2001
From: CoprDistGit <infra@openeuler.org>
Date: Fri, 25 Oct 2024 21:58:12 +0000
Subject: automatic import of python-multipart

---
 python-multipart.spec | 59 +++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 59 insertions(+)
 create mode 100644 python-multipart.spec

(limited to 'python-multipart.spec')

diff --git a/python-multipart.spec b/python-multipart.spec
new file mode 100644
index 0000000..8fd18b3
--- /dev/null
+++ b/python-multipart.spec
@@ -0,0 +1,59 @@
+%global pypi_name multipart
+
+Name:           python-%{pypi_name}
+Version:        0.2.5
+Release:        1
+Summary:        Parser for multipart/form-data
+
+License:        MIT
+URL:            http://github.com/defnull/multipart
+Source0:        https://files.pythonhosted.org/packages/ad/ff/6f8d8a6635d20e6d5932bf34facc6ee50184f585411e65ef556744d55a49/multipart-0.2.5.tar.gz
+BuildArch:      noarch
+
+BuildRequires:  python3-devel
+BuildRequires:  python3-setuptools
+
+%description
+Parser for multipart/form-data This module provides a parser for the
+multipart/form-data format. It can read from a file, a socket or a WSGI
+environment. The parser can be used to replace cgi.FieldStorage to work around
+its limitations.
+
+%package -n     python3-%{pypi_name}
+Summary:        %{summary}
+%{?python_provide:%python_provide python3-%{pypi_name}}
+
+%description -n python3-%{pypi_name}
+Parser for multipart/form-data This module provides a parser for the
+multipart/form-data format. It can read from a file, a socket or a WSGI
+environment. The parser can be used to replace cgi.FieldStorage to work around
+its limitations.
+
+
+%prep
+%autosetup -n %{pypi_name}-%{version}
+# Remove bundled egg-info
+rm -rf %{pypi_name}.egg-info
+
+%build
+%py3_build
+
+%install
+%py3_install
+
+%files -n python3-%{pypi_name}
+%license LICENSE
+%doc README.rst
+%{python3_sitelib}/__pycache__/*
+%{python3_sitelib}/%{pypi_name}.py
+%{python3_sitelib}/%{pypi_name}-%{version}-py%{python3_version}.egg-info
+
+%changelog
+* Fri Aug 02 2024 muxiaohui <muxiaohui@kylinos.cn> - 0.2.5-1
+- Update package to version 0.2.5
+- Add official support for Python 3.10-3.12
+- Update URL for Bottle
+- Add python-requires directive, indicating Python 3.5 or later is required and preventing older Pythons from attempting to download this version
+
+* Thu Nov 11 2021 zhangkea <zhangkea@uniontech.com> - 0.2.4-1
+- Initial package.
-- 
cgit v1.2.3