summaryrefslogtreecommitdiff
path: root/python-twine.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-twine.spec')
-rw-r--r--python-twine.spec102
1 files changed, 102 insertions, 0 deletions
diff --git a/python-twine.spec b/python-twine.spec
new file mode 100644
index 0000000..a33b80d
--- /dev/null
+++ b/python-twine.spec
@@ -0,0 +1,102 @@
+%global _empty_manifest_terminate_build 0
+%global common_description \
+twine Twine is a utility for publishing Python packages on PyPI.
+
+Name: python-twine
+Version: 6.0.1
+Release: 1
+Summary: Collection of utilities for publishing packages on PyPI
+License: Apache-2.0
+URL: https://twine.readthedocs.io/
+Source0: https://files.pythonhosted.org/packages/2c/33/88b80116504b61759fa2db05e13f2296b0d2e73568f5e731d020c13843b8/twine-6.0.1.tar.gz
+BuildArch: noarch
+%description
+%{common_description}
+
+%package -n python3-twine
+Summary: Collection of utilities for publishing packages on PyPI
+Provides: python-twine
+# Base build requires
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pbr
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+# General build requires
+BuildRequires: python3-pkginfo >= 1.8.1
+BuildRequires: python3-readme-renderer >= 35.0
+BuildRequires: python3-requests >= 2.20
+BuildRequires: python3-requests-toolbelt >= 0.8.0
+BuildRequires: python3-urllib3 >= 1.26.0
+BuildRequires: python3-keyring >= 15.1
+BuildRequires: python3-rfc3986 >= 1.4.0
+BuildRequires: python3-rich >= 12.0.0
+BuildRequires: python3-packaging
+BuildRequires: python3-keyring >= 15.1
+# General requires
+Requires: python3-pkginfo >= 1.8.1
+Requires: python3-readme-renderer >= 35.0
+Requires: python3-requests >= 2.20
+Requires: python3-requests-toolbelt >= 0.8.0
+Requires: python3-urllib3 >= 1.26.0
+Requires: python3-keyring >= 15.1
+Requires: python3-rfc3986 >= 1.4.0
+Requires: python3-rich >= 12.0.0
+Requires: python3-packaging
+Requires: python3-keyring >= 15.1
+%description -n python3-twine
+%{common_description}
+
+%package help
+Summary: Collection of utilities for publishing packages on PyPI
+Provides: python3-twine-doc
+%description help
+%{common_description}
+
+%prep
+%autosetup -n twine-%{version}
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+
+%files -n python3-twine -f filelist.lst
+%dir %{python3_sitelib}/*
+%exclude %{python3_sitelib}/twine/__pycache__/*.pyc
+%exclude %{python3_sitelib}/twine/*/__pycache__/*.pyc
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Dec 19 2024 OpenStack_SIG <openstack@openeuler.org> - 6.0.1-1
+- Init package python3-twine of version 6.0.1