summaryrefslogtreecommitdiff
path: root/python-frontmatter.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-frontmatter.spec')
-rw-r--r--python-frontmatter.spec48
1 files changed, 48 insertions, 0 deletions
diff --git a/python-frontmatter.spec b/python-frontmatter.spec
new file mode 100644
index 0000000..d191947
--- /dev/null
+++ b/python-frontmatter.spec
@@ -0,0 +1,48 @@
+%global modname frontmatter
+
+Name: python-%{modname}
+Version: 1.1.0
+Release: 1%{?dist}
+Summary: A small package to load and parse files (or just text) with YAML (or JSON, TOML or other) front matter.
+
+License: MIT
+URL: https://github.com/eyeseast/python-frontmatter
+Source0: %{pypi_source python-frontmatter}
+
+BuildArch: noarch
+
+BuildRequires: python3-devel
+
+%global _description %{expand:
+This is a small package to load and parse files (or just text) with YAML (or JSON, TOML or other) front matter.}
+
+%description %{_description}
+
+%package -n python3-%{modname}
+Summary: %{summary}
+
+%description -n python3-%{modname}
+%{_description}
+
+%prep
+%autosetup -n python-%{modname}-%{version} -p 1
+
+%build
+%py3_build
+
+%install
+%py3_install
+
+%check
+
+%files -n python3-%{modname}
+%license LICENSE
+%{python3_sitelib}/python_frontmatter-*.egg-info/
+%{python3_sitelib}/%{modname}/*
+
+%changelog
+* Tue Wed 07 2024 weilinfox <caiweilin@iscas.ac.cn> - 1.1.0-1
+- Upgrade package to version 1.1.0
+
+* Tue Feb 06 2024 weilinfox <caiweilin@iscas.ac.cn> - 1.0.1-1
+- Build for openEuler 2309