summaryrefslogtreecommitdiff
path: root/python-pockets.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-08-22 07:29:35 +0000
committerCoprDistGit <infra@openeuler.org>2023-08-22 07:29:35 +0000
commit125258701a100d1af75e476f39c87ab4a82ffa36 (patch)
treec3050cd372335fdc9c41402f5ff027b8093b22c4 /python-pockets.spec
parent8231039ffd48d1f0a450a30b96c261715b7188b0 (diff)
automatic import of python-pocketsopeneuler23.03
Diffstat (limited to 'python-pockets.spec')
-rw-r--r--python-pockets.spec47
1 files changed, 47 insertions, 0 deletions
diff --git a/python-pockets.spec b/python-pockets.spec
new file mode 100644
index 0000000..54b2561
--- /dev/null
+++ b/python-pockets.spec
@@ -0,0 +1,47 @@
+%global pypi_name pockets
+
+Name: python-%{pypi_name}
+Version: 0.9.1
+Release: 1
+Summary: A collection of helpful Python tools!
+
+License: MIT
+URL: https://github.com/RobRuana/pockets
+Source0: https://files.pythonhosted.org/packages/df/8e/0601097cfcce2e8c2297db5080e9719f549c2bd4b94420ddc8d3f848bbca/%{pypi_name}-%{version}.tar.gz
+BuildArch: noarch
+
+%description
+The Pockets library pulls together many of the Python helper functions I've found useful over the years.
+
+%package -n python3-%{pypi_name}
+Summary: A collection of helpful Python tools!
+Provides: python-%{pypi_name}
+
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-poetry-core
+
+%description -n python3-%{pypi_name}
+The Pockets library pulls together many of the Python helper functions I've found useful over the years.
+
+%prep
+%autosetup -n %{pypi_name}-%{version}
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+
+%files -n python3-%{pypi_name}
+%license LICENSE
+%doc README.rst
+%{python3_sitelib}/pockets-*.dist-info/
+%{python3_sitelib}/pockets/
+
+%changelog
+* Mon Aug 21 2023 mengzhaoa <mengzhaoa@isoftstone.com> - 0.9.1-1
+- Init package python-pockets.