summaryrefslogtreecommitdiff
path: root/kunpengsecl.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kunpengsecl.spec')
-rw-r--r--kunpengsecl.spec100
1 files changed, 13 insertions, 87 deletions
diff --git a/kunpengsecl.spec b/kunpengsecl.spec
index 23bc33e..2d739f9 100644
--- a/kunpengsecl.spec
+++ b/kunpengsecl.spec
@@ -1,41 +1,34 @@
%global name kunpengsecl
-%global version 2.0.2
+%global version 1.1.2
%undefine _missing_build_ids_terminate_build
Name: %{name}
Version: %{version}
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: A remote attestation security software components running on Kunpeng processors.
Summary(zh_CN): 一款运行于鲲鹏处理器上的远程证明安全软件组件
License: MulanPSL-2.0
URL: https://gitee.com/openeuler/kunpengsecl
Source0: %{name}-v%{version}.tar.gz
Source1: vendor.tar.gz
+Patch0: kunpengsecl-fix-incorrect-file-permissions.patch
BuildRequires: gettext make golang
-BuildRequires: protobuf-compiler openssl-devel
-BuildRequires: cjson-devel
-%ifarch aarch64
-BuildRequires: itrustee_sdk-devel
-%endif
+BuildRequires: protobuf-compiler compat-openssl11-devel
-Packager: leezhenxiang, WangLi, Wucaijun, gwei3
+Requires: compat-openssl11
+Packager: WangLi, Wucaijun, gwei3
%description
-This is %{name} project, including rac, ras, rahub, qcaserver, attester and tas packages.
+This is %{name} project, including rac, ras and rahub packages.
%package rac
Summary: the rac package.
-Requires: openssl
-%ifarch aarch64
-Requires: itrustee_sdk
-%endif
%description rac
This is the rac rpm package, which is used to install the client of the program.
%package ras
Summary: the ras package.
-Requires: %{name}-attester
%description ras
This is the ras rpm package, which is used to install the server of the program.
@@ -46,36 +39,9 @@ Summary: the rahub package.
%description rahub
This is the rahub rpm package, which is used to cascade clients.
-%package qcaserver
-Summary: the qcaserver package.
-
-%description qcaserver
-This is the qcaserver rpm package, which is used to invoke libqca.
-
-%package attester
-Summary: the attester package.
-Requires: cjson
-Requires: openssl
-
-%description attester
-This is the attester rpm package, which is used to verify ta reports.
-
-%package tas
-Summary: the tas package.
-Requires: %{name}-attester
-
-%description tas
-This is the tas rpm package, which is used to sign ak cert.
-
-%package devel
-Summary: the develop package.
-Requires: %{name}-attester
-
-%description devel
-This is the devel rpm package, which provide supporting header file.
-
%prep
%setup -q -c -a 1
+%patch0 -p1
%build
make build
@@ -103,9 +69,6 @@ make install DESTDIR=%{buildroot}
%{_docdir}/attestation/rac/README.md
%{_docdir}/attestation/rac/README.en.md
%{_docdir}/attestation/rac/LICENSE
-%ifarch aarch64
-%{_libdir}/libkta.so
-%endif
%files ras
%{_bindir}/ras
@@ -128,49 +91,12 @@ make install DESTDIR=%{buildroot}
%{_docdir}/attestation/rahub/README.en.md
%{_docdir}/attestation/rahub/LICENSE
-%files qcaserver
-%{_bindir}/qcaserver
-%{_sysconfdir}/attestation/qcaserver/config.yaml
-%{_datadir}/attestation/qcaserver/prepare-qcaconf-env.sh
-%{_docdir}/attestation/qcaserver/README.md
-%{_docdir}/attestation/qcaserver/README.en.md
-%{_docdir}/attestation/qcaserver/LICENSE
-%{_datadir}/attestation/qcaserver/libqca.so
-%{_datadir}/attestation/qcaserver/libteec.so
-
-%files attester
-%{_bindir}/attester
-%{_sysconfdir}/attestation/attester/config.yaml
-%{_datadir}/attestation/attester/prepare-attesterconf-env.sh
-%{_docdir}/attestation/attester/README.md
-%{_docdir}/attestation/attester/README.en.md
-%{_docdir}/attestation/attester/LICENSE
-%{_libdir}/libteeverifier.so
-
-%files tas
-%{_bindir}/tas
-%{_bindir}/*.pem
-%{_sysconfdir}/attestation/tas/config.yaml
-%{_datadir}/attestation/tas/prepare-tasconf-env.sh
-%{_docdir}/attestation/tas/README.md
-%{_docdir}/attestation/tas/README.en.md
-%{_docdir}/attestation/tas/LICENSE
-
-%files devel
-%{_includedir}/teeverifier.h
-
%changelog
-* Thu Jul 18 2023 leezhenxiang <1172294056@qq.com> - 2.0.2-1
-- update to 2.0.2
-* Thu Mar 23 2023 leezhenxiang <1172294056@qq.com> - 2.0.1-1
-- update to 2.0.1
-- add devel package
-* Thu Mar 23 2023 leezhenxiang <1172294056@qq.com> - 2.0.0-1
-- update to 2.0.0
-- add qcaserver, attester, and tas packages
-- add BuildRequires itrustee_sdk-devel, cjson-devel and Requires itrustee_sdk, cjson
-- modify makefile to adapt to different architectures
-- specify the build requires in rac and attester package
+* Wed Apr 26 2023 Xiaoya Huang <huangxiaoya@iscas.ac.cn> - 1.1.2-3
+- Fix incorrect file permissions
+* Fri Feb 10 2023 gwei3 <11015100@qq.com> - 1.1.2-2
+- update BuildRequires & Requires to replace openssl* with compat-openssl11* to adapt to latest Mainline
+- remove redundent clean label in spec file
* Thu Sep 15 2022 gwei3 <11015100@qq.com> - 1.1.2-1
- update to 1.1.2
- add slice length checks to avoid buffer overflow while extracting and verifying