summaryrefslogtreecommitdiff
path: root/file-reorganize.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-01-08 12:57:05 +0000
committerCoprDistGit <infra@openeuler.org>2025-01-08 12:57:05 +0000
commitec684d143ec86a3da890547c85bc75ef0eed2296 (patch)
tree5980938039fcaae0aa2cec0b622189fe42699edc /file-reorganize.spec
parentc7e50674a4b9365192c2cced0aad8b53c79359ae (diff)
automatic import of file-reorganize
Diffstat (limited to 'file-reorganize.spec')
-rw-r--r--file-reorganize.spec12
1 files changed, 7 insertions, 5 deletions
diff --git a/file-reorganize.spec b/file-reorganize.spec
index 87cb08d..08e8f8b 100644
--- a/file-reorganize.spec
+++ b/file-reorganize.spec
@@ -7,7 +7,7 @@ License: MulanPSL2.0
URL: https://atomgit.com/openeuler123/x_haihua.git
Source0: %{name}-%{version}.tar.gz
-BuildRequires: dnf-plugins-core, binutils, glibc-devel, gcc-c++, openssl
+BuildRequires: wget, dnf-plugins-core, binutils, glibc-devel, gcc-c++, openssl
%define debug_package %{nil}
@@ -20,11 +20,13 @@ BuildRequires: dnf-plugins-core, binutils, glibc-devel, gcc-c++, openssl
# 安装cangjie
plt=`uname -m`
if [[ $plt -eq "x86_64" ]]; then
- mv %{_builddir}/%{name}-%{version}/lib/cangjie_x86_64 /root/cangjie
- source /root/cangjie/envsetup.sh
+ wget wget -O Cangjie-0.53.13-linux_x64.tar.gz "https://cangjie-lang.cn/v1/files/auth/downLoad?nsId=142267&fileName=Cangjie-0.53.13-linux_x64.tar.gz&objectKey=6719f1eb3af6947e3c6af327"
+ tar -xzvf Cangjie-0.53.13-linux_x64.tar.gz
+ source cangjie/envsetup.sh
else
- mv %{_builddir}/%{name}-%{version}/lib/cangjie_aarch64/root/cangjie
- source /root/cangjie/envsetup.sh
+ wget -O Cangjie-0.53.13-linux_aarch64.tar.gz "https://cangjie-lang.cn/v1/files/auth/downLoad?nsId=142267&fileName=Cangjie-0.53.13-linux_aarch64.tar.gz&objectKey=6719f1ec3af6947e3c6af328"
+ tar -xzvf Cangjie-0.53.13-linux_aarch64.tar.gz
+ source cangjie/envsetup.sh
fi
%build