summaryrefslogtreecommitdiff
path: root/text.spec
diff options
context:
space:
mode:
Diffstat (limited to 'text.spec')
-rw-r--r--text.spec47
1 files changed, 47 insertions, 0 deletions
diff --git a/text.spec b/text.spec
new file mode 100644
index 0000000..8298f51
--- /dev/null
+++ b/text.spec
@@ -0,0 +1,47 @@
+%global commit 0.13.0
+%global shortcommit %(c=%{commit}; echo ${c:0:7})
+
+Name: torchtext
+Version: 0.13.0
+Release: 1%{?dist}
+Summary: Natural Language Processing library for PyTorch
+
+License: BSD
+URL: https://github.com/pytorch/text
+Source0: https://github.com/pytorch/text/archive/v%{version}.tar.gz
+
+BuildRequires: gcc
+BuildRequires: gcc-c++
+BuildRequires: cmake
+BuildRequires: python3-devel
+BuildRequires: python3-numpy
+BuildRequires: python3-scipy
+BuildRequires: python3-scikit-learn
+BuildRequires: python3-matplotlib
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-torch
+
+%description
+torchtext is a Natural Language Processing (NLP) library for PyTorch. It provides data
+processing, datasets, and models for tasks such as text classification, language
+modeling, and sequence-to-sequence learning.
+
+%prep
+%autosetup -n text-%{commit}
+
+%build
+export TORCHTEXT_BUILD_VERSION=%{version}
+export TORCHTEXT_BUILD_NUMBER=1
+python3 setup.py bdist_wheel
+
+%install
+%py3_install
+
+%files
+%{python3_sitelib}/*
+
+%changelog
+* Sat Apr 15 2023 Your Name <your.name@example.com> - 0.13.0-1
+- Initial package