summaryrefslogtreecommitdiff
path: root/text.spec
diff options
context:
space:
mode:
Diffstat (limited to 'text.spec')
-rw-r--r--text.spec57
1 files changed, 57 insertions, 0 deletions
diff --git a/text.spec b/text.spec
new file mode 100644
index 0000000..68287ff
--- /dev/null
+++ b/text.spec
@@ -0,0 +1,57 @@
+%global commit 0.13.0
+%global shortcommit %(c=%{commit}; echo ${c:0:7})
+%global pypi_name torchtext
+
+Name: torchtext
+Version: 0.13.0
+Release: 1%{?dist}
+Summary: Natural Language Processing library for PyTorch
+
+License: BSD
+URL: https://github.com/pytorch/text
+Source0: https://github.com/pytorch/text/archive/v%{version}.tar.gz
+
+
+BuildRequires: cmake
+BuildRequires: ninja-build
+BuildRequires: utf8proc-devel
+BuildRequires: re2-devel
+BuildRequires: double-conversion-devel
+BuildRequires: sentencepiece
+
+BuildRequires: python3-numpy
+BuildRequires: python3-scipy
+BuildRequires: python3-scikit-learn
+BuildRequires: python3-tqdm
+BuildRequires: python3-requests
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-pbr
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
+
+BuildRequires: python3-pytorch
+
+%description
+torchtext is a Natural Language Processing (NLP) library for PyTorch. It provides data
+processing, datasets, and models for tasks such as text classification, language
+modeling, and sequence-to-sequence learning.
+
+%prep
+%autosetup -n text-%{commit}
+
+%build
+%py3_build
+
+%install
+%py3_install
+
+%files
+%{python3_sitelib}/*
+%{python3_sitearch}/%{name}
+
+%changelog
+* Sat Apr 15 2023 chelsey20011128@gmail.com - 0.13.0-1
+- Initial package