summaryrefslogtreecommitdiff
path: root/base.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-04-15 18:48:20 +0000
committerCoprDistGit <infra@openeuler.org>2024-04-15 18:48:20 +0000
commite882ff085b74990db9e387b845e1317f3f2740c3 (patch)
treec7462ac8778129e95645307941f2fd89684410f8 /base.spec
parentc247d70878366943daaafd550b62cd5822291e6b (diff)
automatic import of deepspeed
Diffstat (limited to 'base.spec')
-rw-r--r--base.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/base.spec b/base.spec
new file mode 100644
index 0000000..839fb4c
--- /dev/null
+++ b/base.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+%global _unpackaged_files_terminate_build 0
+
+# using global macro to speed up the spec editing
+%global pkg_name deepspeed
+%global version 0.14.0
+%global pkg_summary A deep learning optimization library
+%global pkg_desc %{expand:%{pkg_summary}}
+%global open_license Apache-2.0
+
+Name: %{pkg_name}
+Version: %{version}
+Release: 1
+Summary: %{pkg_summary}
+License: %{open_license}
+
+# the url and source0 url here
+URL: https://www.deepspeed.ai/
+Source0: https://github.com/microsoft/DeepSpeed/archive/refs/tags/v0.14.0.tar.gz
+
+BuildRequires: g++
+BuildRequires: cmake
+BuildRequires: ninja
+BuildRequires: ninja-build
+
+# build requires
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
+BuildRequires: python3-setuptools_scm
+
+# higharchy desc
+%description
+%{pkg_summary}
+
+# sub pkg section 1
+%package -n python3-%{pkg_name}
+Summary: a python3-lib provides transformers functionality
+
+%description -n python3-%{pkg_name}
+python3-transformers provides APIs for transformers realize.
+
+# pkg section: help optional
+# %package -n help
+# Summary: docs for the transformers
+# Provides: python3-transformers-doc
+# %description -n help
+# description for the doc of the python3-transformers
+
+# the name here should match the name of the dir of the source code zip
+# which got from the .tar.gz unzipped
+%prep
+%autosetup -p1 -n DeepSpeed-%{version}
+
+# using python poject build, supplied by setup.py or pyproject.toml
+%build
+%pyproject_build
+
+# using python project install, supplied by setup.py or pyproject.toml
+%install
+%pyproject_install
+
+# point out the files here
+%files -n python3-%{pkg_name}
+%doc *.md
+%license LICENSE*
+%{python3_sitearch}/python_%{pkg_name}/*
+# %{python3_sitelib}/python_%{pkg_name}/*
+
+
+%changelog
+* Sat April 15 2024 youser<1328699220@qq.com>
+- pkg init