summaryrefslogtreecommitdiff
path: root/base.spec
diff options
context:
space:
mode:
Diffstat (limited to 'base.spec')
-rw-r--r--base.spec70
1 files changed, 0 insertions, 70 deletions
diff --git a/base.spec b/base.spec
deleted file mode 100644
index 3735293..0000000
--- a/base.spec
+++ /dev/null
@@ -1,70 +0,0 @@
-%global _empty_manifest_terminate_build 0
-%global _unpackaged_files_terminate_build 0
-
-# using global macro to speed up the spec editing
-%global pkg_name pytorch-lightning
-%global version 2.2.2
-%global pkg_summary pytorch-lightning is used to process text data
-%global pkg_desc %{expand:%{pkg_summary}}
-%global open_license opensource_license
-
-Name: %{pkg_name}
-Version: %{version}
-Release: 1
-Summary: %{pkg_summary}
-License: %{open_license}
-
-# the url and source0 url here
-URL: https://pypi.org/project/pytorch-lightning/
-Source0: https://files.pythonhosted.org/packages/c1/d0/b3155686f9b0a0e593b65ab39fb08f051d172dd13986c044a698d2adb127/pytorch-lightning-2.2.2.tar.gz
-
-# build requires
-BuildRequires: python3-devel
-BuildRequires: python3-setuptools
-BuildRequires: python3-pip
-BuildRequires: python3-wheel
-BuildRequires: python3-hatchling
-BuildRequires: python3-setuptools_scm
-
-# higharchy desc
-%description
-%{pkg_summary}
-
-# sub pkg section 1
-%package -n python3-%{pkg_name}
-Summary: %{pkg_summary}
-
-%description -n python3-%{pkg_name}
-python3-transformers provides APIs for transformers realize.
-
-# pkg section: help optional
-# %package -n help
-# Summary: docs for the transformers
-# Provides: python3-transformers-doc
-# %description -n help
-# description for the doc of the python3-transformers
-
-# the name here should match the name of the dir of the source code zip
-# which got from the .tar.gz unzipped
-%prep
-%autosetup -p1 -n pytorch-lightning-%{version}
-
-# using python poject build, supplied by setup.py or pyproject.toml
-%build
-%pyproject_build
-
-# using python project install, supplied by setup.py or pyproject.toml
-%install
-%pyproject_install
-
-# point out the files here
-%files -n python3-%{pkg_name}
-%doc *.md
-%license LICENSE*
-# %{python3_sitearch}/python_%{pkg_name}/*
-%{python3_sitelib}/python_%{pkg_name}/*
-
-
-%changelog
-* Sat April 15 2024 youser<1328699220@qq.com>
-- pkg init