summaryrefslogtreecommitdiff
path: root/torchtext.spec
diff options
context:
space:
mode:
Diffstat (limited to 'torchtext.spec')
-rw-r--r--torchtext.spec12
1 files changed, 7 insertions, 5 deletions
diff --git a/torchtext.spec b/torchtext.spec
index dc88449..0ceba70 100644
--- a/torchtext.spec
+++ b/torchtext.spec
@@ -6,7 +6,7 @@
%global version 0.17.2
%global pkg_summary torchtext is used to process text data
%global pkg_desc %{pkg_summary}
-%global pkg_license BSD 3-Clause
+%global pkg_license BSD-3-Clause
Name: %{pkg_name}
Version: %{version}
@@ -66,10 +66,12 @@ Summary: %{pkg_summary}
# the name here should match the name of tar.gz file
%prep
%autosetup -p1 -n text-%{version}
-tar -xvf re2-2024-04-1.tar.gz -C text-%{version}/third_party
-tar -xvf sentencepiece-0.2.0.tar.gz -C text-%{version}/third_party
-tar -xvf utf8proc-2.9.0.tar.gz -C text-%{version}/third_party
-tar -xvf double-conversion-3.3.0.tar.gz -C text-%{version}/third_party
+tar -xvf %{_sourcedir}/re2-2024-04-1.tar.gz -C text-%{version}/third_party
+tar -xvf %{_sourcedir}/sentencepiece-0.2.0.tar.gz -C text-%{version}/third_party
+tar -xvf %{_sourcedir}/utf8proc-2.9.0.tar.gz -C text-%{version}/third_party
+tar -xvf %{_sourcedir}/double-conversion-3.3.0.tar.gz -C text-%{version}/third_party
+cd text-%{version}
+ls -lh
%build
%pyproject_build