summaryrefslogtreecommitdiff
path: root/torchtext.spec
diff options
context:
space:
mode:
Diffstat (limited to 'torchtext.spec')
-rw-r--r--torchtext.spec66
1 files changed, 66 insertions, 0 deletions
diff --git a/torchtext.spec b/torchtext.spec
new file mode 100644
index 0000000..54447e5
--- /dev/null
+++ b/torchtext.spec
@@ -0,0 +1,66 @@
+%global _empty_manifest_terminate_build 0
+%global _unpackaged_files_terminate_build 0
+
+# set global to speedup the spec editing
+%global pkg_name torchtext
+%global version 0.17.2
+%global pkg_summary torchtext is used to process text data
+%global pkg_desc %{pkg_summary}
+%global pkg_license BSD 3-Clause
+
+Name: %{pkg_name}
+Version: %{version}
+Release: 1
+Summary: %{pkg_summary}
+License: %{pkg_license}
+
+# the url and source
+URL: https://pytorch.org/text/stable/index.html
+Source0: https://github.com/pytorch/text/archive/refs/tags/v%{version}.tar.gz
+
+# build requires
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
+BuildRequires: python3-setuptools_scm
+
+%description
+%{pkg_summary}
+
+# sub pkg section 1
+%package -n python3-%{pkg_name}
+Summary: a python3-lib provides text processing functionality
+
+%description -n python3-%{pkg_name}
+python3-transformers provides APIs for transformers realize.
+
+# pkg section: help optional
+# %package -n help
+# Summary: docs for the transformers
+# Provides: python3-transformers-doc
+# %description -n help
+# description for the doc of the python3-transformers
+
+
+# the name here should match the name of tar.gz file
+%prep
+%autosetup -p1 -n text-%{version}
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+
+%files -n python3-%{pkg_name}
+%doc README*
+%license LICENSE*
+%{python3_sitearch}/python_%{pkg_name}/*
+# %{python3_sitelib}/python_%{pkg_name}/*
+
+
+%changelog
+* Sat April 15 2024 youser<1328699220@qq.com>
+- pkg init