summaryrefslogtreecommitdiff
path: root/python-oic.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-04-02 08:41:39 +0000
committerCoprDistGit <infra@openeuler.org>2025-04-02 08:41:39 +0000
commitc5c97d0922e864a9428652ee6057032707952a18 (patch)
tree7b87f3d6af3a436d00784b7114369604fcb7822c /python-oic.spec
parente0d51c8b5b035964b871238a39bb66c37462540c (diff)
automatic import of python-oicopeneuler24.09
Diffstat (limited to 'python-oic.spec')
-rw-r--r--python-oic.spec108
1 files changed, 108 insertions, 0 deletions
diff --git a/python-oic.spec b/python-oic.spec
new file mode 100644
index 0000000..d672676
--- /dev/null
+++ b/python-oic.spec
@@ -0,0 +1,108 @@
+%global _empty_manifest_terminate_build 0
+Name: python-oic
+Version: 1.7.0
+Release: 1
+Summary: Python implementation of OAuth2 and OpenID Connect
+License: Apache 2.0
+URL: https://github.com/CZ-NIC/pyoidc/
+Source0: https://mirrors.aliyun.com/pypi/web/packages/bc/22/1f46483b2095750161b862a034e334bf471f4a8c865e39058502983a73ea/oic-1.7.0.tar.gz
+BuildArch: noarch
+
+Requires: (python3-requests)
+Requires: (python3-pycryptodomex)
+Requires: (python3-pydantic-settings)
+Requires: (python3-pyjwkest>=1.3.6)
+Requires: (python3-mako)
+Requires: (python3-cryptography)
+Requires: (python3-defusedxml)
+Requires: (python3-typing-extensions)
+Requires: (python3-cherrypy==3.2.4)
+Requires: (python3-pyOpenSSL)
+Requires: (python3-Sphinx)
+Requires: (python3-sphinx-autobuild)
+Requires: (python3-alabaster)
+Requires: (python3-autodoc-pydantic>=2.0.0)
+Requires: (python3-beaker)
+Requires: (python3-python-ldap)
+Requires: (python3-pylama)
+Requires: (python3-isort)
+Requires: (python3-eradicate)
+Requires: (python3-mypy)
+Requires: (python3-black)
+Requires: (python3-bandit)
+Requires: (python3-readme-renderer[md])
+Requires: (python3-responses)
+Requires: (python3-testfixtures)
+Requires: (python3-pytest)
+Requires: (python3-freezegun)
+Requires: (python3-types-requests)
+
+%description
+This is a complete implementation of OpenID Connect as specified in the `OpenID
+Connect Core specification`_. And as a side effect, a complete implementation
+of OAuth2.0 too.
+Please see the `CHANGELOG.md`_ to review the latest changes.
+
+%package -n python3-oic
+Summary: Python implementation of OAuth2 and OpenID Connect
+Provides: python-oic
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+%description -n python3-oic
+This is a complete implementation of OpenID Connect as specified in the `OpenID
+Connect Core specification`_. And as a side effect, a complete implementation
+of OAuth2.0 too.
+Please see the `CHANGELOG.md`_ to review the latest changes.
+
+%package help
+Summary: Development documents and examples for oic
+Provides: python3-oic-doc
+%description help
+This is a complete implementation of OpenID Connect as specified in the `OpenID
+Connect Core specification`_. And as a side effect, a complete implementation
+of OAuth2.0 too.
+Please see the `CHANGELOG.md`_ to review the latest changes.
+
+%prep
+%autosetup -n oic-1.7.0
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+touch filelist.lst
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-oic -f filelist.lst
+%{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 02 2025 Python_Bot <Python_Bot@openeuler.org> - 1.7.0-1
+- Package Spec generated