%global _empty_manifest_terminate_build 0
Name: python-retask
Version: 1.1.0
Release: 1
Summary: Task Queue implementation in python using redis.
License: MIT License
URL: https://pypi.org/project/retask/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4e/4a/2d5e40f1999f7951b6fc0617fca6a0eccd45dab12aac4cd0f26757f9354f/retask-1.1.0.tar.gz
BuildArch: noarch
Requires: python3-redis
%description
retask is a python module to create distributed task
queues using Redis.
You can read the latest documentation `here `_.
Release build is done via [asaman](https://pypi.org/project/asaman/) from the tarball.
%package -n python3-retask
Summary: Task Queue implementation in python using redis.
Provides: python-retask
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-retask
retask is a python module to create distributed task
queues using Redis.
You can read the latest documentation `here `_.
Release build is done via [asaman](https://pypi.org/project/asaman/) from the tarball.
%package help
Summary: Development documents and examples for retask
Provides: python3-retask-doc
%description help
retask is a python module to create distributed task
queues using Redis.
You can read the latest documentation `here `_.
Release build is done via [asaman](https://pypi.org/project/asaman/) from the tarball.
%prep
%autosetup -n retask-1.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-retask -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Mar 21 2023 Python_Bot - 1.1.0-1
- Package Spec generated