%global pypi_name pyLibravatar
%global pypi_version 1.7

Name:           python-%{pypi_name}
Version:        %{pypi_version}
Release:        2
Summary:        Python module for Libravatar

License:        MIT
URL:            https://launchpad.net/pylibravatar
Source0:        https://files.pythonhosted.org/packages/source/%/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
BuildArch:      noarch

BuildRequires:  python3-devel
BuildRequires:  python3-setuptools

%description
PyLibravatar is an easy way to make use of the federated Libravatar_ avatar
hosting service from within your Python applications.

%package -n     python3-%{pypi_name}
Summary:        %{summary}
%{?python_provide:%python_provide python3-%{pypi_name}}
Requires:       python3-py3dns

%description -n python3-%{pypi_name}
PyLibravatar is an easy way to make use of the federated Libravatar_ avatar
hosting service from within your Python applications.


%prep
%autosetup -n %{pypi_name}-%{pypi_version}

%build
%py3_build

%install
%py3_install

%files -n python3-%{pypi_name}
%doc README.txt
%{python3_sitelib}/__pycache__/*
%{python3_sitelib}/libravatar.py
%{python3_sitelib}/%{pypi_name}-%{pypi_version}-py%{python3_version}.egg-info

%changelog
* Wed Mar 29 2023 lichaoran <pkwarcraft@hotmail.com> - 1.7-2
- add py3dns as dep

* Thu Jan 27 2022 zhangkea <zhangkea@uniontech.com> - 1.7-1
- Initial package.