%global _empty_manifest_terminate_build 0
Name:		python-blessed
Version:	1.20.0
Release:	1
Summary:	Easy, practical library for making terminal apps, by providing an elegant, well-documented interface to Colors, Keyboard input, and screen Positioning capabilities.
License:	MIT
URL:		https://github.com/jquast/blessed
Source0:        https://files.pythonhosted.org/packages/25/ae/92e9968ad23205389ec6bd82e2d4fca3817f1cdef34e10aa8d529ef8b1d7/blessed-1.20.0.tar.gz
BuildArch:	noarch

Requires:	python3-wcwidth
Requires:	python3-six
Requires:	python3-jinxed
Requires:	python3-ordereddict

%description
Blessed is an easy, practical library for making python terminal apps

%package -n python3-blessed
Summary:	Easy, practical library for making terminal apps, by providing an elegant, well-documented interface to Colors, Keyboard input, and screen Positioning capabilities.
Provides:	python-blessed
BuildRequires:	python3-devel
BuildRequires:	zlib >= 1.2.11
BuildRequires:	python3-setuptools
%description -n python3-blessed
Blessed is an easy, practical library for making python terminal apps

%package help
Summary:	Development documents and examples for blessed
Provides:	python3-blessed-doc
%description help
Blessed is an easy, practical library for making python terminal apps

%prep
%autosetup -n blessed-%{version}

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-blessed -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 2 2023 wubijie <wubijie@kylinos.cn> - 1.20.0-1
- Update package to version 1.20.0

* Thu Oct 27 2022 wangjunqi <wangjunqi@kylinos.cn> - 1.19.1-1
- Update package to version 1.19.1

* Fri Apr 22 2022 liqiuyu <liqiuyu@kylinos.cn> - 1.19.0-2
- Add zlib to buildrequires 

* Tue Dec 07 2021 Python_Bot <Python_Bot@openeuler.org> - 1.19.0-1
- Package Init