%global _empty_manifest_terminate_build 0
Name:		python-Naked
Version:	0.1.32
Release:	1
Summary:	A command line application framework
License:	MIT
URL:		https://github.com/chrissimpkins/naked
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/47/a5/7a4f84bb6a7b0d6ba84fda48119e29afd339a1bc4f9589dab1fe064d6eb6/Naked-0.1.32.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-pyyaml

%description
A command line application framework


%package -n python3-Naked
Summary:	A command line application framework
Provides:	python-Naked
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Naked
A command line application framework


%package help
Summary:	Development documents and examples for Naked
Provides:	python3-Naked-doc
%description help
A command line application framework


%prep
%autosetup -n Naked-0.1.32

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Naked -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Mar 06 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.32-1
- Package Spec generated