%global _empty_manifest_terminate_build 0
Name:		python-bidict
Version:	0.22.1
Release:	1
Summary:	The bidirectional mapping library for Python.
License:	MPL 2.0
URL:		https://bidict.readthedocs.io
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f2/be/b31e6ea9c94096a323e7a0e2c61480db01f07610bb7e7ea72a06fd1a23a8/bidict-0.22.1.tar.gz
BuildArch:	noarch

Requires:	python3-sphinx
Requires:	python3-sphinx-copybutton
Requires:	python3-furo
Requires:	python3-pre-commit
Requires:	python3-hypothesis
Requires:	python3-pytest
Requires:	python3-pytest-benchmark[histogram]
Requires:	python3-pytest-cov
Requires:	python3-pytest-xdist
Requires:	python3-sortedcollections
Requires:	python3-sortedcontainers
Requires:	python3-sphinx

%description
*The bidirectional mapping library for Python.*

%package -n python3-bidict
Summary:	The bidirectional mapping library for Python.
Provides:	python-bidict
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-bidict
*The bidirectional mapping library for Python.*

%package help
Summary:	Development documents and examples for bidict
Provides:	python3-bidict-doc
%description help
*The bidirectional mapping library for Python.*

%prep
%autosetup -n bidict-0.22.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-bidict -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed Mar 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.22.1-1
- Package Spec generated