%global _empty_manifest_terminate_build 0
Name:		python-django-doc
Version:	1.1
Release:	1
Summary:	Automate Django RestFramework Documentation
License:	MIT
URL:		https://github.com/digifyshop/django-doc
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/56/18/dbf332796f6f21e54a1a8995d86497071027f6c38964796a623fda552dcf/django-doc-1.1.tar.gz
BuildArch:	noarch


%description
- Add `django-doc` to your installed_apps
- Run Python `python manage.py collectdoc`


%package -n python3-django-doc
Summary:	Automate Django RestFramework Documentation
Provides:	python-django-doc
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-doc
- Add `django-doc` to your installed_apps
- Run Python `python manage.py collectdoc`


%package help
Summary:	Development documents and examples for django-doc
Provides:	python3-django-doc-doc
%description help
- Add `django-doc` to your installed_apps
- Run Python `python manage.py collectdoc`


%prep
%autosetup -n django-doc-1.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-doc -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1-1
- Package Spec generated