%global _empty_manifest_terminate_build 0
Name: python-django-registration
Version: 3.3
Release: 1
Summary: An extensible user-registration application for Django
License: BSD License
URL: https://github.com/ubernostrum/django-registration/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ed/c4/4db23e4d62d710735154cdbafb3ac4b6a2937996ff4313a4888a8160f3e6/django-registration-3.3.tar.gz
BuildArch: noarch
Requires: python3-Django
Requires: python3-confusable-homoglyphs
%description
.. -*-restructuredtext-*-
.. image:: https://github.com/ubernostrum/django-registration/workflows/CI/badge.svg
:alt: CI status image
:target: https://github.com/ubernostrum/django-registration/actions?query=workflow%3ACI
This is a user-registration application for `Django
`_. There are two registration
workflows (one-step, and two-step with activation) built in, and it's
designed to be extensible and support building additional workflows.
To get started, check out `the documentation
`_.
%package -n python3-django-registration
Summary: An extensible user-registration application for Django
Provides: python-django-registration
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-registration
.. -*-restructuredtext-*-
.. image:: https://github.com/ubernostrum/django-registration/workflows/CI/badge.svg
:alt: CI status image
:target: https://github.com/ubernostrum/django-registration/actions?query=workflow%3ACI
This is a user-registration application for `Django
`_. There are two registration
workflows (one-step, and two-step with activation) built in, and it's
designed to be extensible and support building additional workflows.
To get started, check out `the documentation
`_.
%package help
Summary: Development documents and examples for django-registration
Provides: python3-django-registration-doc
%description help
.. -*-restructuredtext-*-
.. image:: https://github.com/ubernostrum/django-registration/workflows/CI/badge.svg
:alt: CI status image
:target: https://github.com/ubernostrum/django-registration/actions?query=workflow%3ACI
This is a user-registration application for `Django
`_. There are two registration
workflows (one-step, and two-step with activation) built in, and it's
designed to be extensible and support building additional workflows.
To get started, check out `the documentation
`_.
%prep
%autosetup -n django-registration-3.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-registration -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 3.3-1
- Package Spec generated