%global _empty_manifest_terminate_build 0
Name: python-dropbox
Version: 11.36.0
Release: 1
Summary: Official Dropbox API Client
License: MIT License
URL: http://www.dropbox.com/developers
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/89/d7/42792461014f5c434e070c8d4727a7e8aa1ed1e24726a62bbececc7b49dd/dropbox-11.36.0.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-six
Requires: python3-stone
%description
Create an app via the `Developer Console`_.
Install via `pip `_:
$ pip install dropbox
Install from source:
$ git clone git://github.com/dropbox/dropbox-sdk-python.git
$ cd dropbox-sdk-python
$ python setup.py install
After installation, follow one of our `Examples`_ or read the documentation on `Read The Docs`_.
You can also view our `OAuth Guide`_.
%package -n python3-dropbox
Summary: Official Dropbox API Client
Provides: python-dropbox
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dropbox
Create an app via the `Developer Console`_.
Install via `pip `_:
$ pip install dropbox
Install from source:
$ git clone git://github.com/dropbox/dropbox-sdk-python.git
$ cd dropbox-sdk-python
$ python setup.py install
After installation, follow one of our `Examples`_ or read the documentation on `Read The Docs`_.
You can also view our `OAuth Guide`_.
%package help
Summary: Development documents and examples for dropbox
Provides: python3-dropbox-doc
%description help
Create an app via the `Developer Console`_.
Install via `pip `_:
$ pip install dropbox
Install from source:
$ git clone git://github.com/dropbox/dropbox-sdk-python.git
$ cd dropbox-sdk-python
$ python setup.py install
After installation, follow one of our `Examples`_ or read the documentation on `Read The Docs`_.
You can also view our `OAuth Guide`_.
%prep
%autosetup -n dropbox-11.36.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dropbox -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 11.36.0-1
- Package Spec generated