%global _empty_manifest_terminate_build 0
Name: python-epc
Version: 0.0.5
Release: 1
Summary: EPC (RPC stack for Emacs Lisp) implementation in Python
License: GNU General Public License v3 (GPLv3)
URL: https://github.com/tkf/python-epc
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/55/ae/f7b329fa2bc9932a416e8846e78e06ce3e13a20e5c3f2cf80a18f489dec1/epc-0.0.5.tar.gz
BuildArch: noarch
%description
Links:
* `Documentation `_ (at Read the Docs)
* `Repository `_ (at GitHub)
* `Issue tracker `_ (at GitHub)
* `PyPI `_
* `Travis CI `_ |build-status|
Other resources:
* `kiwanami/emacs-epc `_
(Client and server implementation in Emacs Lisp and Perl.)
* `tkf/emacs-jedi `_
(Python completion for Emacs using EPC server.)
image:: https://secure.travis-ci.org/tkf/python-epc.png
?branch=master
%package -n python3-epc
Summary: EPC (RPC stack for Emacs Lisp) implementation in Python
Provides: python-epc
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-epc
Links:
* `Documentation `_ (at Read the Docs)
* `Repository `_ (at GitHub)
* `Issue tracker `_ (at GitHub)
* `PyPI `_
* `Travis CI `_ |build-status|
Other resources:
* `kiwanami/emacs-epc `_
(Client and server implementation in Emacs Lisp and Perl.)
* `tkf/emacs-jedi `_
(Python completion for Emacs using EPC server.)
image:: https://secure.travis-ci.org/tkf/python-epc.png
?branch=master
%package help
Summary: Development documents and examples for epc
Provides: python3-epc-doc
%description help
Links:
* `Documentation `_ (at Read the Docs)
* `Repository `_ (at GitHub)
* `Issue tracker `_ (at GitHub)
* `PyPI `_
* `Travis CI `_ |build-status|
Other resources:
* `kiwanami/emacs-epc `_
(Client and server implementation in Emacs Lisp and Perl.)
* `tkf/emacs-jedi `_
(Python completion for Emacs using EPC server.)
image:: https://secure.travis-ci.org/tkf/python-epc.png
?branch=master
%prep
%autosetup -n epc-0.0.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-epc -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 0.0.5-1
- Package Spec generated