%global _empty_manifest_terminate_build 0
Name: python-fedmsg
Version: 1.1.3
Release: 1
Summary: Fedora Messaging Client API
License: LGPLv2+
URL: https://github.com/fedora-infra/fedmsg/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/95/33/9db97f470e64f85de2f29d7a491289bede82adc6fc5795a7132f86ce38b6/fedmsg-1.1.3.tar.gz
BuildArch: noarch
%description
.. image:: https://img.shields.io/pypi/v/fedmsg.svg
:target: https://pypi.python.org/pypi/fedmsg
.. image:: https://img.shields.io/pypi/pyversions/fedmsg.svg
:target: https://pypi.python.org/pypi/fedmsg
.. image:: https://img.shields.io/pypi/l/fedmsg.svg
:target: https://pypi.python.org/pypi/fedmsg
.. image:: https://readthedocs.org/projects/docs/badge/?version=latest
:alt: Documentation Status
:target: https://fedmsg.readthedocs.io/en/latest/?badge=latest
.. image:: https://secure.travis-ci.org/fedora-infra/fedmsg.png?branch=develop
:alt: Build Status - develop branch
:target: https://travis-ci.org/#!/fedora-infra/fedmsg
.. image:: https://codecov.io/github/fedora-infra/fedmsg/coverage.svg?branch=develop
:target: https://codecov.io/github/fedora-infra/fedmsg
:alt: codecov.io
fedmsg (Federated Message Bus) is a library built on ZeroMQ using the PyZMQ Python bindings.
fedmsg aims to make it easy to connect services together using ZeroMQ publishers and
subscribers.
Note that this library is deprecated in favor of https://github.com/fedora-infra/fedora-messaging
Check out the `documentation `_ for installation and
configuration instructions.
%package -n python3-fedmsg
Summary: Fedora Messaging Client API
Provides: python-fedmsg
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fedmsg
.. image:: https://img.shields.io/pypi/v/fedmsg.svg
:target: https://pypi.python.org/pypi/fedmsg
.. image:: https://img.shields.io/pypi/pyversions/fedmsg.svg
:target: https://pypi.python.org/pypi/fedmsg
.. image:: https://img.shields.io/pypi/l/fedmsg.svg
:target: https://pypi.python.org/pypi/fedmsg
.. image:: https://readthedocs.org/projects/docs/badge/?version=latest
:alt: Documentation Status
:target: https://fedmsg.readthedocs.io/en/latest/?badge=latest
.. image:: https://secure.travis-ci.org/fedora-infra/fedmsg.png?branch=develop
:alt: Build Status - develop branch
:target: https://travis-ci.org/#!/fedora-infra/fedmsg
.. image:: https://codecov.io/github/fedora-infra/fedmsg/coverage.svg?branch=develop
:target: https://codecov.io/github/fedora-infra/fedmsg
:alt: codecov.io
fedmsg (Federated Message Bus) is a library built on ZeroMQ using the PyZMQ Python bindings.
fedmsg aims to make it easy to connect services together using ZeroMQ publishers and
subscribers.
Note that this library is deprecated in favor of https://github.com/fedora-infra/fedora-messaging
Check out the `documentation `_ for installation and
configuration instructions.
%package help
Summary: Development documents and examples for fedmsg
Provides: python3-fedmsg-doc
%description help
.. image:: https://img.shields.io/pypi/v/fedmsg.svg
:target: https://pypi.python.org/pypi/fedmsg
.. image:: https://img.shields.io/pypi/pyversions/fedmsg.svg
:target: https://pypi.python.org/pypi/fedmsg
.. image:: https://img.shields.io/pypi/l/fedmsg.svg
:target: https://pypi.python.org/pypi/fedmsg
.. image:: https://readthedocs.org/projects/docs/badge/?version=latest
:alt: Documentation Status
:target: https://fedmsg.readthedocs.io/en/latest/?badge=latest
.. image:: https://secure.travis-ci.org/fedora-infra/fedmsg.png?branch=develop
:alt: Build Status - develop branch
:target: https://travis-ci.org/#!/fedora-infra/fedmsg
.. image:: https://codecov.io/github/fedora-infra/fedmsg/coverage.svg?branch=develop
:target: https://codecov.io/github/fedora-infra/fedmsg
:alt: codecov.io
fedmsg (Federated Message Bus) is a library built on ZeroMQ using the PyZMQ Python bindings.
fedmsg aims to make it easy to connect services together using ZeroMQ publishers and
subscribers.
Note that this library is deprecated in favor of https://github.com/fedora-infra/fedora-messaging
Check out the `documentation `_ for installation and
configuration instructions.
%prep
%autosetup -n fedmsg-1.1.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fedmsg -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 1.1.3-1
- Package Spec generated