%global _empty_manifest_terminate_build 0
Name: python-Frozen-Flask
Version: 0.18
Release: 1
Summary: Freezes a Flask application into a set of static files.
License: BSD
URL: https://github.com/Frozen-Flask/Frozen-Flask
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a2/d5/a540c1d251a186bb911f3458b4cb220f2499a059585dba86d805a38ef96b/Frozen-Flask-0.18.tar.gz
BuildArch: noarch
Requires: python3-Flask
%description
Freezes a Flask application into a set of static files. The result can be hosted
without any server-side software other than a traditional web server.
Links
`````
* `documentation `_
* `development version
`_
%package -n python3-Frozen-Flask
Summary: Freezes a Flask application into a set of static files.
Provides: python-Frozen-Flask
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Frozen-Flask
Freezes a Flask application into a set of static files. The result can be hosted
without any server-side software other than a traditional web server.
Links
`````
* `documentation `_
* `development version
`_
%package help
Summary: Development documents and examples for Frozen-Flask
Provides: python3-Frozen-Flask-doc
%description help
Freezes a Flask application into a set of static files. The result can be hosted
without any server-side software other than a traditional web server.
Links
`````
* `documentation `_
* `development version
`_
%prep
%autosetup -n Frozen-Flask-0.18
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Frozen-Flask -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 0.18-1
- Package Spec generated