%global _empty_manifest_terminate_build 0
Name:		python-insteon
Version:	0.0.2
Release:	1
Summary:	A utility for interacting with insteon modems and hubs
License:	MIT License
URL:		https://github.com/pfrommerd/python-insteon
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b4/a2/419ad9d1665495d86f4c3edb2fa93a1e25b60cc97f0d116c119d3ae479ca/insteon-0.0.2.tar.gz
BuildArch:	noarch

Requires:	python3-aioserial
Requires:	python3-logbook
Requires:	python3-setuptools

%description
A set of utilities for interacting with insteon modems and hubs

Used as a backend for the Insteon Terminal and several insteon plugins




%package -n python3-insteon
Summary:	A utility for interacting with insteon modems and hubs
Provides:	python-insteon
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-insteon
A set of utilities for interacting with insteon modems and hubs

Used as a backend for the Insteon Terminal and several insteon plugins




%package help
Summary:	Development documents and examples for insteon
Provides:	python3-insteon-doc
%description help
A set of utilities for interacting with insteon modems and hubs

Used as a backend for the Insteon Terminal and several insteon plugins




%prep
%autosetup -n insteon-0.0.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-insteon -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.2-1
- Package Spec generated