%global _empty_manifest_terminate_build 0
Name:		python-into-dbus-python
Version:	0.8
Release:	1
Summary:	transforms values into properly wrapped dbus-python objects
License:	Apache 2.0
URL:		https://github.com/stratis-storage/into-dbus-python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d6/02/32987a5c3d5b881d65a4c109fbaad6b058504b874143250d92f80f3b9905/into-dbus-python-0.8.tar.gz
BuildArch:	noarch

Requires:	python3-dbus-signature-pyparsing
Requires:	python3-dbus-python

%description
Facilities for converting an object that inhabits core Python types, e.g.,
lists, ints, dicts, to an object that inhabits dbus-python types, e.g.,
dbus.Array, dbus.UInt32, dbus.Dictionary based on a specified dbus signature.

%package -n python3-into-dbus-python
Summary:	transforms values into properly wrapped dbus-python objects
Provides:	python-into-dbus-python
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-into-dbus-python
Facilities for converting an object that inhabits core Python types, e.g.,
lists, ints, dicts, to an object that inhabits dbus-python types, e.g.,
dbus.Array, dbus.UInt32, dbus.Dictionary based on a specified dbus signature.

%package help
Summary:	Development documents and examples for into-dbus-python
Provides:	python3-into-dbus-python-doc
%description help
Facilities for converting an object that inhabits core Python types, e.g.,
lists, ints, dicts, to an object that inhabits dbus-python types, e.g.,
dbus.Array, dbus.UInt32, dbus.Dictionary based on a specified dbus signature.

%prep
%autosetup -n into-dbus-python-0.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-into-dbus-python -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8-1
- Package Spec generated