%global _empty_manifest_terminate_build 0
Name:		python-med
Version:	0.0.1
Release:	1
Summary:	Django project
License:	MIT
URL:		https://github.com/mag1i/med.git
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/e6/7e/26472baf80c6895a6553d4c8e04e08f4c05416efa0aaf2386a3479e9363f/med-0.0.1.tar.gz
BuildArch:	noarch

Requires:	python3-Django

%description
# med
Hospital website written in Django




%package -n python3-med
Summary:	Django project
Provides:	python-med
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-med
# med
Hospital website written in Django




%package help
Summary:	Development documents and examples for med
Provides:	python3-med-doc
%description help
# med
Hospital website written in Django




%prep
%autosetup -n med-0.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-med -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.1-1
- Package Spec generated