%global _empty_manifest_terminate_build 0
Name: python-mulpyplexer
Version: 0.09
Release: 1
Summary: A module that multiplexes interactions with lists of python objects.
License: BSD
URL: https://pypi.org/project/mulpyplexer/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d7/6f/f036d4fb9f5a511262345bb18215c70fa69a250aca2e5ffe1a9c7e4cb85c/mulpyplexer-0.09.tar.gz
BuildArch: noarch
%description
Mulpyplexer is a piece of code that can multiplex interactions with lists of python objects.
It's easier to show you:
import mulpyplexer
class A:
def __init__(self, i):
self.i = i
def add(self, j):
return A(self.i + (j.i if isinstance(j, A) else j))
def sub(self, j):
return A(self.i - (j.i if isinstance(j, A) else j))
def __repr__(self):
return "" % self.i
def str(self):
return str(self.i)
def __eq__(self, o):
return self.i == o.i
one = mulpyplexer.MP([ A(10), A(20), A(30) ])
two = one.add(5)
assert two.mp_items == [ A(15), A(25), A(35) ]
three = two.sub(10)
assert three.mp_items == [ A(5), A(15), A(25) ]
four = three.add(one)
assert four.mp_items == [ A(15), A(35), A(55) ]
five = four.str()
assert five.mp_items == [ "15", "35", "55" ]
six = four.i
assert six.mp_items == [ 15, 35, 55 ]
%package -n python3-mulpyplexer
Summary: A module that multiplexes interactions with lists of python objects.
Provides: python-mulpyplexer
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-mulpyplexer
Mulpyplexer is a piece of code that can multiplex interactions with lists of python objects.
It's easier to show you:
import mulpyplexer
class A:
def __init__(self, i):
self.i = i
def add(self, j):
return A(self.i + (j.i if isinstance(j, A) else j))
def sub(self, j):
return A(self.i - (j.i if isinstance(j, A) else j))
def __repr__(self):
return "" % self.i
def str(self):
return str(self.i)
def __eq__(self, o):
return self.i == o.i
one = mulpyplexer.MP([ A(10), A(20), A(30) ])
two = one.add(5)
assert two.mp_items == [ A(15), A(25), A(35) ]
three = two.sub(10)
assert three.mp_items == [ A(5), A(15), A(25) ]
four = three.add(one)
assert four.mp_items == [ A(15), A(35), A(55) ]
five = four.str()
assert five.mp_items == [ "15", "35", "55" ]
six = four.i
assert six.mp_items == [ 15, 35, 55 ]
%package help
Summary: Development documents and examples for mulpyplexer
Provides: python3-mulpyplexer-doc
%description help
Mulpyplexer is a piece of code that can multiplex interactions with lists of python objects.
It's easier to show you:
import mulpyplexer
class A:
def __init__(self, i):
self.i = i
def add(self, j):
return A(self.i + (j.i if isinstance(j, A) else j))
def sub(self, j):
return A(self.i - (j.i if isinstance(j, A) else j))
def __repr__(self):
return "" % self.i
def str(self):
return str(self.i)
def __eq__(self, o):
return self.i == o.i
one = mulpyplexer.MP([ A(10), A(20), A(30) ])
two = one.add(5)
assert two.mp_items == [ A(15), A(25), A(35) ]
three = two.sub(10)
assert three.mp_items == [ A(5), A(15), A(25) ]
four = three.add(one)
assert four.mp_items == [ A(15), A(35), A(55) ]
five = four.str()
assert five.mp_items == [ "15", "35", "55" ]
six = four.i
assert six.mp_items == [ 15, 35, 55 ]
%prep
%autosetup -n mulpyplexer-0.09
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-mulpyplexer -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 0.09-1
- Package Spec generated