%global _empty_manifest_terminate_build 0
Name:		python-natsort
Version:	8.3.1
Release:	1
Summary:	Simple yet flexible natural sorting in Python.
License:	MIT
URL:		https://github.com/SethMMorton/natsort
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/47/2a/bf13bfc1a51b6df2f823909c6d4f674a256e3f29401825e1d56ca2a95dc9/natsort-8.3.1.tar.gz
BuildArch:	noarch

Requires:	python3-fastnumbers
Requires:	python3-PyICU

%description
Simple yet flexible natural sorting in Python.
    - Source Code: https://github.com/SethMMorton/natsort
    - Downloads: https://pypi.org/project/natsort/
    - Documentation: https://natsort.readthedocs.io/
      - `Examples and Recipes`_
      - `How Does Natsort Work?`_
      - `API`_
    - `Quick Description`_
    - `Quick Examples`_
    - `FAQ`_
    - `Requirements`_
    - `Optional Dependencies`_
    - `Installation`_
    - `How to Run Tests`_
    - `How to Build Documentation`_
    - `Dropped Deprecated APIs`_
    - `History`_
**NOTE**: Please see the `Dropped Deprecated APIs`_ section for changes.

%package -n python3-natsort
Summary:	Simple yet flexible natural sorting in Python.
Provides:	python-natsort
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-natsort
Simple yet flexible natural sorting in Python.
    - Source Code: https://github.com/SethMMorton/natsort
    - Downloads: https://pypi.org/project/natsort/
    - Documentation: https://natsort.readthedocs.io/
      - `Examples and Recipes`_
      - `How Does Natsort Work?`_
      - `API`_
    - `Quick Description`_
    - `Quick Examples`_
    - `FAQ`_
    - `Requirements`_
    - `Optional Dependencies`_
    - `Installation`_
    - `How to Run Tests`_
    - `How to Build Documentation`_
    - `Dropped Deprecated APIs`_
    - `History`_
**NOTE**: Please see the `Dropped Deprecated APIs`_ section for changes.

%package help
Summary:	Development documents and examples for natsort
Provides:	python3-natsort-doc
%description help
Simple yet flexible natural sorting in Python.
    - Source Code: https://github.com/SethMMorton/natsort
    - Downloads: https://pypi.org/project/natsort/
    - Documentation: https://natsort.readthedocs.io/
      - `Examples and Recipes`_
      - `How Does Natsort Work?`_
      - `API`_
    - `Quick Description`_
    - `Quick Examples`_
    - `FAQ`_
    - `Requirements`_
    - `Optional Dependencies`_
    - `Installation`_
    - `How to Run Tests`_
    - `How to Build Documentation`_
    - `Dropped Deprecated APIs`_
    - `History`_
**NOTE**: Please see the `Dropped Deprecated APIs`_ section for changes.

%prep
%autosetup -n natsort-8.3.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-natsort -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 8.3.1-1
- Package Spec generated