%global _empty_manifest_terminate_build 0
Name: python-raven
Version: 6.10.0
Release: 1
Summary: Raven is a client for Sentry (https://getsentry.com)
License: BSD
URL: https://github.com/getsentry/raven-python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/79/57/b74a86d74f96b224a477316d418389af9738ba7a63c829477e7a86dd6f47/raven-6.10.0.tar.gz
BuildArch: noarch
Requires: python3-contextlib2
Requires: python3-Flask
Requires: python3-blinker
Requires: python3-bottle
Requires: python3-celery
Requires: python3-coverage
Requires: python3-exam
Requires: python3-flake8
Requires: python3-logbook
Requires: python3-mock
Requires: python3-nose
Requires: python3-pytz
Requires: python3-pytest
Requires: python3-pytest-timeout
Requires: python3-pytest-xdist
Requires: python3-pytest-pythonpath
Requires: python3-pytest-cov
Requires: python3-pytest-flake8
Requires: python3-requests
Requires: python3-tornado
Requires: python3-tox
Requires: python3-webob
Requires: python3-webtest
Requires: python3-wheel
Requires: python3-anyjson
Requires: python3-ZConfig
Requires: python3-Flask
Requires: python3-blinker
Requires: python3-Flask-Login
Requires: python3-blinker
Requires: python3-sanic
Requires: python3-aiohttp
%description
Raven is a Python client for `Sentry `_. It provides
full out-of-the-box support for many of the popular frameworks, including
`Django `_, `Flask `_, and `Pylons
`_. Raven also includes drop-in support for any
`WSGI `_-compatible web application.
%package -n python3-raven
Summary: Raven is a client for Sentry (https://getsentry.com)
Provides: python-raven
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-raven
Raven is a Python client for `Sentry `_. It provides
full out-of-the-box support for many of the popular frameworks, including
`Django `_, `Flask `_, and `Pylons
`_. Raven also includes drop-in support for any
`WSGI `_-compatible web application.
%package help
Summary: Development documents and examples for raven
Provides: python3-raven-doc
%description help
Raven is a Python client for `Sentry `_. It provides
full out-of-the-box support for many of the popular frameworks, including
`Django `_, `Flask `_, and `Pylons
`_. Raven also includes drop-in support for any
`WSGI `_-compatible web application.
%prep
%autosetup -n raven-6.10.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-raven -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 6.10.0-1
- Package Spec generated