%global _empty_manifest_terminate_build 0
Name: python-productivity
Version: 0.8.1
Release: 1
Summary: Python driver for AutomationDirect Productivity Series PLCs.
License: GPLv2
URL: http://github.com/numat/productivity/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d6/a0/cebafdf049dd319c3c6dbad59fe9ce1d3add37038553af4192d4ce931654/productivity-0.8.1.tar.gz
BuildArch: noarch
Requires: python3-PyYAML
Requires: python3-pymodbus
Requires: python3-pymodbus
Requires: python3-pymodbus
Requires: python3-pymodbus
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-asyncio
%description
##### NOTE: This is in very early stages of development.
Python ≥3.7 driver and command-line tool for [AutomationDirect Productivity Series PLCs](https://www.automationdirect.com/adc/overview/catalog/programmable_controllers/productivity_series_controllers).
%package -n python3-productivity
Summary: Python driver for AutomationDirect Productivity Series PLCs.
Provides: python-productivity
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-productivity
##### NOTE: This is in very early stages of development.
Python ≥3.7 driver and command-line tool for [AutomationDirect Productivity Series PLCs](https://www.automationdirect.com/adc/overview/catalog/programmable_controllers/productivity_series_controllers).
%package help
Summary: Development documents and examples for productivity
Provides: python3-productivity-doc
%description help
##### NOTE: This is in very early stages of development.
Python ≥3.7 driver and command-line tool for [AutomationDirect Productivity Series PLCs](https://www.automationdirect.com/adc/overview/catalog/programmable_controllers/productivity_series_controllers).
%prep
%autosetup -n productivity-0.8.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-productivity -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 07 2023 Python_Bot - 0.8.1-1
- Package Spec generated