%global _empty_manifest_terminate_build 0
Name:		python-pwntools
Version:	4.9.0
Release:	1
Summary:	Pwntools CTF framework and exploit development library.
License:	Mostly MIT, some GPL/BSD, see LICENSE-pwntools.txt
URL:		https://pwntools.com
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/6d/df/8d94f7c63ef35fdd1b2ee2ac1c54b308754a7e532af2a36b0cb77bd03542/pwntools-4.9.0.tar.gz
BuildArch:	noarch

Requires:	python3-paramiko
Requires:	python3-mako
Requires:	python3-pyelftools
Requires:	python3-capstone
Requires:	python3-ropgadget
Requires:	python3-pyserial
Requires:	python3-requests
Requires:	python3-pip
Requires:	python3-pygments
Requires:	python3-pysocks
Requires:	python3-dateutil
Requires:	python3-packaging
Requires:	python3-psutil
Requires:	python3-intervaltree
Requires:	python3-sortedcontainers
Requires:	python3-unicorn
Requires:	python3-six
Requires:	python3-rpyc
Requires:	python3-colored-traceback

%description
   pwntools logo
|PyPI| |Docs| |Travis| |GitHub Workflow Status (branch)| |Coveralls|
|MIT License| |Packaging status| |Discord| |Twitter|
Pwntools is a CTF framework and exploit development library. Written in
Python, it is designed for rapid prototyping and development, and
intended to make exploit writing as simple as possible.
   from pwn import *
   context(arch = 'i386', os = 'linux')
   r = remote('exploitme.example.com', 31337)
   # EXPLOIT CODE GOES HERE
   r.send(asm(shellcraft.sh()))
   r.interactive()

%package -n python3-pwntools
Summary:	Pwntools CTF framework and exploit development library.
Provides:	python-pwntools
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pwntools
   pwntools logo
|PyPI| |Docs| |Travis| |GitHub Workflow Status (branch)| |Coveralls|
|MIT License| |Packaging status| |Discord| |Twitter|
Pwntools is a CTF framework and exploit development library. Written in
Python, it is designed for rapid prototyping and development, and
intended to make exploit writing as simple as possible.
   from pwn import *
   context(arch = 'i386', os = 'linux')
   r = remote('exploitme.example.com', 31337)
   # EXPLOIT CODE GOES HERE
   r.send(asm(shellcraft.sh()))
   r.interactive()

%package help
Summary:	Development documents and examples for pwntools
Provides:	python3-pwntools-doc
%description help
   pwntools logo
|PyPI| |Docs| |Travis| |GitHub Workflow Status (branch)| |Coveralls|
|MIT License| |Packaging status| |Discord| |Twitter|
Pwntools is a CTF framework and exploit development library. Written in
Python, it is designed for rapid prototyping and development, and
intended to make exploit writing as simple as possible.
   from pwn import *
   context(arch = 'i386', os = 'linux')
   r = remote('exploitme.example.com', 31337)
   # EXPLOIT CODE GOES HERE
   r.send(asm(shellcraft.sh()))
   r.interactive()

%prep
%autosetup -n pwntools-4.9.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pwntools -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 4.9.0-1
- Package Spec generated