%global _empty_manifest_terminate_build 0
Name:		python-pynuvo
Version:	0.2
Release:	1
Summary:	Python API for talking to Nuvo multi zone amplifier
License:	MIT License
URL:		https://github.com/ejonesnospam/pynuvo
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/8b/b6/355cdfb26d9804b63b196d8c5f3325b5884224d794ed3f76d4de248c2cfa/pynuvo-0.2.tar.gz
BuildArch:	noarch

Requires:	python3-pyserial

%description
# pynuvo
Python3 interface implementation for Nuvo zone amplifier
 Initially developed/tested with older Concerto model
*** Should/could also work with any Nuvo amp, via RS-232 serial, such NV-E6D

## Notes
This is for use with [Home-Assistant](http://home-assistant.io)

## Usage
```python

```





%package -n python3-pynuvo
Summary:	Python API for talking to Nuvo multi zone amplifier
Provides:	python-pynuvo
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pynuvo
# pynuvo
Python3 interface implementation for Nuvo zone amplifier
 Initially developed/tested with older Concerto model
*** Should/could also work with any Nuvo amp, via RS-232 serial, such NV-E6D

## Notes
This is for use with [Home-Assistant](http://home-assistant.io)

## Usage
```python

```





%package help
Summary:	Development documents and examples for pynuvo
Provides:	python3-pynuvo-doc
%description help
# pynuvo
Python3 interface implementation for Nuvo zone amplifier
 Initially developed/tested with older Concerto model
*** Should/could also work with any Nuvo amp, via RS-232 serial, such NV-E6D

## Notes
This is for use with [Home-Assistant](http://home-assistant.io)

## Usage
```python

```





%prep
%autosetup -n pynuvo-0.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pynuvo -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2-1
- Package Spec generated